summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/renderdoc/renderdoc-1.17.ebuild')
-rw-r--r--dev-util/renderdoc/renderdoc-1.17.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-util/renderdoc/renderdoc-1.17.ebuild b/dev-util/renderdoc/renderdoc-1.17.ebuild
index daf8e3e..a6bdb7e 100644
--- a/dev-util/renderdoc/renderdoc-1.17.ebuild
+++ b/dev-util/renderdoc/renderdoc-1.17.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+PYTHON_COMPAT=( python3_{6,7,8,9,10} )
inherit qmake-utils cmake eutils python-single-r1
SWIG_VERSION="7"
@@ -44,8 +44,6 @@ DEPEND="${RDEPEND}
app-arch/unzip"
src_configure() {
- export QT_SELECT=qt5
- export QMAKE_QT5_COMMAND=qmake-qt5
local mycmakeargs=(
-DENABLE_EGL="$(usex egl)"
-DENABLE_GL="$(usex opengl)"
@@ -55,6 +53,7 @@ src_configure() {
-DENABLE_WAYLAND="$(usex wayland)"
-DENABLE_XCB="$(usex xcb)"
-DBUILD_VERSION_STABLE=ON
+ -DQMAKE_QT5_COMMAND="qmake5"
-DRENDERDOC_SWIG_PACKAGE="${DISTDIR}/${SWIG_ZIP_FILENAME}"
)
cmake_src_configure