summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/rsstorrent/rsstorrent-0.8-r1.ebuild')
-rw-r--r--net-p2p/rsstorrent/rsstorrent-0.8-r1.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/net-p2p/rsstorrent/rsstorrent-0.8-r1.ebuild b/net-p2p/rsstorrent/rsstorrent-0.8-r1.ebuild
index b1243b0..b808498 100644
--- a/net-p2p/rsstorrent/rsstorrent-0.8-r1.ebuild
+++ b/net-p2p/rsstorrent/rsstorrent-0.8-r1.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI="8"
-PYTHON_COMPAT=( python3_{6,7,8,9,10} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=(python3_{9..11})
inherit distutils-r1 vcs-snapshot
DESCRIPTION="Tool for automatically downloading torrents using RSS feeds"
HOMEPAGE="http://azp.github.com/rsstorrent/"
-SRC_URI="https://github.com/AzP/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+SRC_URI="https://github.com/AzP/rsstorrent/archive/v${PV} -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
@@ -27,7 +27,6 @@ python_install_all() {
newinitd "${S}/rsstorrent-openrc" rsstorrent
newconfd "${S}/rsstorrent_conf.d" rsstorrent
- dodir /etc/rsstorrent
insinto /etc/rsstorrent
newins "${S}/rsstorrent.conf" rsstorrent.conf.sample
}