summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoao Carreira <jfmcarreira@gmail.com>2020-04-24 19:49:55 +0100
committerJoao Carreira <jfmcarreira@gmail.com>2020-04-24 19:49:55 +0100
commita61680ee99d6ad1c0d4dfc432dd072fcfee403ea (patch)
tree314a9a587c6b158125e5a15fd72da82eb24a5ca2
parentmedia-video/calyp: reverto to EAPI 6 (diff)
downloadcarreira-a61680ee99d6ad1c0d4dfc432dd072fcfee403ea.tar.gz
carreira-a61680ee99d6ad1c0d4dfc432dd072fcfee403ea.tar.bz2
carreira-a61680ee99d6ad1c0d4dfc432dd072fcfee403ea.zip
kde-misc/ktoshiba: port from kde5 to ecm eclass
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Joao Carreira <jfmcarreira@gmail.com>
-rw-r--r--kde-misc/ktoshiba/ktoshiba-9999.ebuild44
1 files changed, 24 insertions, 20 deletions
diff --git a/kde-misc/ktoshiba/ktoshiba-9999.ebuild b/kde-misc/ktoshiba/ktoshiba-9999.ebuild
index 08b465b..d896247 100644
--- a/kde-misc/ktoshiba/ktoshiba-9999.ebuild
+++ b/kde-misc/ktoshiba/ktoshiba-9999.ebuild
@@ -1,40 +1,44 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit kde5
+KFMIN=5.60.0
+QTMIN=5.12.3
+inherit ecm
-DESCRIPTION="Function (FN) key monitoring for Toshiba laptops"
+DESCRIPTION="Function key (FN) monitoring for Toshiba laptops"
HOMEPAGE="http://ktoshiba.sourceforge.net/"
EGIT_REPO_URI="https://github.com/jfmcarreira/ktoshiba.git"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
+SLOT="5"
KEYWORDS=""
IUSE=""
-RDEPEND="
- $(add_plasma_dep plasma-workspace)
- $(add_frameworks_dep kauth)
- $(add_frameworks_dep kcmutils)
- $(add_frameworks_dep kconfig)
- $(add_frameworks_dep kcoreaddons)
- $(add_frameworks_dep kdbusaddons)
- $(add_frameworks_dep ki18n)
- $(add_frameworks_dep knotifications)
- $(add_frameworks_dep kwidgetsaddons)
- $(add_qt_dep qtdbus)
- $(add_qt_dep qtgui)
- $(add_qt_dep qtwidgets)
- net-libs/libmnl
+BDEPEND="
sys-devel/gettext
"
-
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kauth-${KFMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ net-libs/libmnl
+"
RDEPEND="${DEPEND}"
src_configure() {
local mycmakeargs=(
-DLIBMNL_INCLUDE_DIRS=/usr/include/libmnl
)
- kde5_src_configure
+ ecm_src_configure
}