summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/tox-core/tox-core-9999.ebuild')
-rw-r--r--net-im/tox-core/tox-core-9999.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-im/tox-core/tox-core-9999.ebuild b/net-im/tox-core/tox-core-9999.ebuild
new file mode 100644
index 0000000..ce55711
--- /dev/null
+++ b/net-im/tox-core/tox-core-9999.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit autotools flag-o-matic git-r3 multilib
+
+DESCRIPTION="Free as in freedom Skype replacement"
+HOMEPAGE="http://tox.im/"
+EGIT_REPO_URI="git://github.com/irungentoo/ProjectTox-Core.git
+ https://github.com/irungentoo/ProjectTox-Core.git"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="-nacl ncurses server +sodium static-libs test"
+REQUIRED_USE="^^ ( nacl sodium )"
+
+RDEPEND="virtual/ffmpeg
+ nacl? ( virtual/nacl )
+ ncurses? ( sys-libs/ncurses )
+ sodium? ( dev-libs/libsodium )"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )"
+
+DOCS="README.md"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf \
+ $(use_enable nacl) \
+ $(use_enable server dht-bootstrap-daemon) \
+ $(use_enable test tests) \
+ $(use_enable ncurses ntox) \
+ $(use_enable static-libs static) \
+ --with-nacl-headers=/usr/include/nacl \
+ --with-nacl-libs=/usr/$(get_libdir)/nacl
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ elog "DHT node list is available via https://gist.github.com/Proplex/6124860"
+ elog "or in #tox @ irc.freenode.org"
+}