summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHoang Minh Thang <hoangminhthang@ktqd.org>2012-07-17 12:45:49 +0700
committerHoang Minh Thang <hoangminhthang@ktqd.org>2012-07-17 12:45:49 +0700
commit208c22ff4f11ebec9d3915b701721461b3c43134 (patch)
tree501c93e5314132c48960b1ca47d969e7dbb05ca0
parentfun (diff)
downloadgentoo-vn-208c22ff4f11ebec9d3915b701721461b3c43134.tar.gz
gentoo-vn-208c22ff4f11ebec9d3915b701721461b3c43134.tar.bz2
gentoo-vn-208c22ff4f11ebec9d3915b701721461b3c43134.zip
remove xmind
-rw-r--r--app-misc/xmind-portable/Manifest8
-rw-r--r--app-misc/xmind-portable/files/x-xmind.xml10
-rw-r--r--app-misc/xmind-portable/files/xmind-thumbnailer78
-rw-r--r--app-misc/xmind-portable/files/xmind.16.pngbin1817 -> 0 bytes
-rw-r--r--app-misc/xmind-portable/files/xmind.32.pngbin2987 -> 0 bytes
-rw-r--r--app-misc/xmind-portable/files/xmind.48.pngbin3607 -> 0 bytes
-rw-r--r--app-misc/xmind-portable/files/xmind.schemas30
-rw-r--r--app-misc/xmind-portable/xmind-portable-3.2.1.201011212218.ebuild88
8 files changed, 0 insertions, 214 deletions
diff --git a/app-misc/xmind-portable/Manifest b/app-misc/xmind-portable/Manifest
deleted file mode 100644
index 5e8eabf..0000000
--- a/app-misc/xmind-portable/Manifest
+++ /dev/null
@@ -1,8 +0,0 @@
-AUX x-xmind.xml 396 RMD160 d29541919d23fb2a49fc8893f2c17628c81aaac1 SHA1 4c82177fc14f73543ef0383d7a2108651c917cfc SHA256 2689f82f4e837ec3e14e6b6c21a1977fecd410e933ad706932bc57468a9a601a
-AUX xmind-thumbnailer 2540 RMD160 43eb34b9de72a533de489325c40ba5e97d4e70de SHA1 b6e8a5f1ff89189acf1c5dadc1d9a64571dffc70 SHA256 a8699e9db1cb02882696372654abd3b1a451569b299370404cfe0d5a43552e6b
-AUX xmind.16.png 1817 RMD160 e4bc7ac1a571216758a95f15fa4d058490d7e3c3 SHA1 8da21c1997757eaa8a64711b7d4fcce88897570f SHA256 4c02ca0bb79726fb9b93e0ef7d489b652f1a354a7368d581e2aad8a4c55cb3df
-AUX xmind.32.png 2987 RMD160 7a48056eb483b38cc8fea8accff124097e32bff1 SHA1 5e6cbd73d7161c31834cf5d18f2b4d3b31e41fbb SHA256 e479a23e62507ac30e58f0cd437135400393559ab0129e5aab58e19af4e0be72
-AUX xmind.48.png 3607 RMD160 47025e257be53d6bff58303372518e85891249af SHA1 026e39bde7a07254c592ac2a6df17b874ec3c311 SHA256 42607e943296942f345ae099b2703c4951279856dbf8694d42a74b8a323eed20
-AUX xmind.schemas 965 RMD160 109e2e508af3e8ff6a5b65dbd5b2f732e850f9f6 SHA1 aa89af2786ac8be10fb2e7f33365e2cbac52520f SHA256 907c864e4ea3631149d463563e0d52cf5bbc9f82f551b883af4132237c48da9e
-DIST xmind-portable-3.2.1.201011212218.zip 79750379 RMD160 32d62069da58d517660ab8245c97dd2c6d78fd3f SHA1 34311681b61f3fd9b6b6b6c6188abc3b39c6e61b SHA256 6ce1912614958cbcaefc1efd8bab8482fcfe75acd6ad66e604964762935b9db6
-EBUILD xmind-portable-3.2.1.201011212218.ebuild 2123 RMD160 bbbe6b9d83081f8f95a0c273574e0f1156b4f14a SHA1 2ae999a1d804b8d134dccba8d8c85b1adf9cb06a SHA256 7e0d3c9b5c7a9db7971ba59600fa1d329048292e5447174a2f9552d89317a602
diff --git a/app-misc/xmind-portable/files/x-xmind.xml b/app-misc/xmind-portable/files/x-xmind.xml
deleted file mode 100644
index 57292e9..0000000
--- a/app-misc/xmind-portable/files/x-xmind.xml
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
- <mime-type type="application/x-xmind">
- <sub-class-of type="application/zip"/>
- <comment>XMind Workbook</comment>
- <alias type="application/vnd.xmind.workbook"/>
- <generic-icon name="package-x-generic"/>
- <glob pattern="*.xmind"/>
- </mime-type>
-</mime-info>
diff --git a/app-misc/xmind-portable/files/xmind-thumbnailer b/app-misc/xmind-portable/files/xmind-thumbnailer
deleted file mode 100644
index 48eb89b..0000000
--- a/app-misc/xmind-portable/files/xmind-thumbnailer
+++ /dev/null
@@ -1,78 +0,0 @@
-#!/usr/bin/env python
-
-import gnomevfs
-import os
-import sys
-import zipfile
-from PIL import Image, ImageEnhance
-
-# Alter these varibles to change thumbnail look
-ICON_PATH = "/usr/share/icons/hicolor/32x32/apps/xmind.png" # Change this path to alter icons
-ICON_OPACITY = 0.6 #Opacity of the icon (between 0.0 and 1.0)
-THUMBNAIL_BACKGROUND_COLOR = "white" # Color of the background
-
-in_file_path = gnomevfs.get_local_path_from_uri(sys.argv[1])
-out_file_path = sys.argv[2]
-path_without_thumbs = os.getenv("HOME")+"/Templates"
-
-def get_icon(thumbnail_size):
- #Load icon
- icon = Image.open(ICON_PATH).convert("RGBA")
- #Set it's opacity
- icon = set_icon_opacity(icon,ICON_OPACITY)
- #And set it's position in thumbnail
- icon_posx=thumbnail_size[0]-icon.size[0]
- icon_posy=thumbnail_size[1]-icon.size[1]
- icon_width=thumbnail_size[0]
- icon_height=thumbnail_size[1]
- return {"image":icon,"position":(icon_posx,icon_posy,icon_width,icon_height)}
-
-def get_basic_thumbnail():
- #Find out if the file is not in Templates directory
- if in_file_path.find(path_without_thumbs)!=0:
- try:
- #Extract thumbnail from Xmind file and save it
- zip=zipfile.ZipFile(in_file_path,mode="r")
- picture=zip.read("Thumbnails/thumbnail.jpg")
- zip.close()
- thumbnail=open(out_file_path,"w")
- thumbnail.write(picture)
- thumbnail.write("/n")
- thumbnail.close()
- #Open saved thumbnail
- image=Image.open(out_file_path).convert("RGBA")
- if image.size[0]>200:
- image = image.resize((200,image.size[1]*200/image.size[0]))
- if image.size[1]>200:
- image = image.resize((image.size[0]*200/image.size[1],200))
- return {"suceeded":True,"image":image,"size":(image.size[0],image.size[1])}
-
- except:
- return {"suceeded":False}
- else:
- return {"suceeded":False}
-
-# Nicked from http://aspn.activestate.com/ASPN/Cookbook/Python/Recipe/362879
-def set_icon_opacity(icon,opacity):
- #Returns an image with reduced opacity.
- assert opacity >= 0 and opacity <= 1
- if icon.mode != 'RGBA':
- icon = icon.convert('RGBA')
- else:
- icon = icon.copy()
- alpha = icon.split()[3]
- alpha = ImageEnhance.Brightness(alpha).enhance(opacity)
- icon.putalpha(alpha)
- return icon
-
-thumbnail=get_basic_thumbnail()
-if thumbnail["suceeded"]:
- background=Image.new("RGB", thumbnail["size"], THUMBNAIL_BACKGROUND_COLOR)
- icon=get_icon(thumbnail["size"])
- thumbnail=thumbnail["image"]
- # Add thumbnail
- background.paste(thumbnail, None, thumbnail)
- # Add icon
- background.paste(icon["image"],icon["position"],icon["image"])
- # Save thumbnail
- background.save(out_file_path,"PNG")
diff --git a/app-misc/xmind-portable/files/xmind.16.png b/app-misc/xmind-portable/files/xmind.16.png
deleted file mode 100644
index 2848087..0000000
--- a/app-misc/xmind-portable/files/xmind.16.png
+++ /dev/null
Binary files differ
diff --git a/app-misc/xmind-portable/files/xmind.32.png b/app-misc/xmind-portable/files/xmind.32.png
deleted file mode 100644
index 4774b25..0000000
--- a/app-misc/xmind-portable/files/xmind.32.png
+++ /dev/null
Binary files differ
diff --git a/app-misc/xmind-portable/files/xmind.48.png b/app-misc/xmind-portable/files/xmind.48.png
deleted file mode 100644
index 6fc816a..0000000
--- a/app-misc/xmind-portable/files/xmind.48.png
+++ /dev/null
Binary files differ
diff --git a/app-misc/xmind-portable/files/xmind.schemas b/app-misc/xmind-portable/files/xmind.schemas
deleted file mode 100644
index 336b09e..0000000
--- a/app-misc/xmind-portable/files/xmind.schemas
+++ /dev/null
@@ -1,30 +0,0 @@
-<gconfschemafile>
- <schemalist>
-
- <schema>
- <key>/schemas/desktop/gnome/thumbnailers/application@x-xmind/enable</key>
- <applyto>/desktop/gnome/thumbnailers/application@x-xmind/enable</applyto>
- <owner>xmind-thumb</owner>
- <type>bool</type>
- <default>true</default>
- <locale name="C">
- <short></short>
- <long></long>
- </locale>
- </schema>
-
-
- <schema>
- <key>/schemas/desktop/gnome/thumbnailers/application@x-xmind/command</key>
- <applyto>/desktop/gnome/thumbnailers/application@x-xmind/command</applyto>
- <owner>xmind-thumb</owner>
- <type>string</type>
- <default>/usr/bin/xmind-thumbnailer %u %o</default>
- <locale name="C">
- <short></short>
- <long></long>
- </locale>
- </schema>
-
- </schemalist>
-</gconfschemafile>
diff --git a/app-misc/xmind-portable/xmind-portable-3.2.1.201011212218.ebuild b/app-misc/xmind-portable/xmind-portable-3.2.1.201011212218.ebuild
deleted file mode 100644
index 4091eb2..0000000
--- a/app-misc/xmind-portable/xmind-portable-3.2.1.201011212218.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-EAPI=3
-
-inherit eutils fdo-mime gnome2-utils
-
-DESCRIPTION="XMind is a brainstorming and mind mapping software tool."
-HOMEPAGE="www.xmind.net"
-SRC_URI="http://dl2.xmind.net/xmind-downloads/${P}.zip"
-
-LICENSE="EPL-1.0 LGPL-3"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="gnome"
-
-DEPEND=">=virtual/jre-1.5"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- unzip -d ${S} ${DISTDIR}/${P}.zip
-}
-
-src_configure() {
- case `arch` in
- "x86_64") XDIR="XMind_Linux_64bit";;
- *) XDIR="XMind_Linux";;
- esac
- mv -v "$XDIR" XMind
-
- # force data instance & config area to be at home/.xmind directory
- sed -i -e '/-Dosgi\.instance\.area=.*/d' XMind/xmind-bin.ini || die
- sed -i -e '/-Dosgi\.configuration\.area=.*/d' XMind/xmind-bin.ini || die
- echo '-Dosgi.instance.area=@user.home/.xmind/workspace-cathy' >> XMind/xmind-bin.ini || die
- echo '-Dosgi.configuration.area=@user.home/.xmind/configuration-cathy' >> XMind/xmind-bin.ini || die
-}
-
-src_compile() {
- einfo "Nothing to compile"
-}
-
-src_install() {
- dodir /usr/lib/xmind
- insinto /usr/lib/xmind
- doins -r Commons
- doins -r XMind
-
- exeinto /usr/lib/xmind/XMind
- doexe XMind/xmind
- doexe XMind/xmind-bin
- dosym /usr/lib/xmind/XMind/xmind /usr/bin/xmind
-
- # insall icons
- local res
- for res in 16 32 48; do
- insinto /usr/share/icons/hicolor/${res}x${res}/apps
- newins ${FILESDIR}/xmind.${res}.png xmind.png || die
- done
-
- # insall MIME type
- insinto /usr/share/mime/packages
- doins "${FILESDIR}"/x-xmind.xml || die
-
- # make desktop entry
- make_desktop_entry xmind XMind xmind Office "MimeType=application/x-xmind;"
- sed -i -e "/^Exec/s/$/ %F/" "${ED}"/usr/share/applications/*.desktop || die
-
- # gnome schemas and thumbnailer
- if use gnome; then
- insinto /etc/gconf/schemas
- doins "${FILESDIR}"/xmind.schemas || die
- dobin "${FILESDIR}"/xmind-thumbnailer || die
- fi
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}