summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustus Ranvier <justusranvier@tormail.org>2012-12-09 13:46:55 -0600
committerJustus Ranvier <justusranvier@tormail.org>2012-12-09 13:46:55 -0600
commit4b0b8e1439c164dda31d0acb71e6b9ac8bf1b621 (patch)
tree3c42a7ed7013032d6abc98dda0fef49bab4d7e6b /net-misc
parentAdd live ebuild for Armory (diff)
downloadjranvier-4b0b8e1439c164dda31d0acb71e6b9ac8bf1b621.tar.gz
jranvier-4b0b8e1439c164dda31d0acb71e6b9ac8bf1b621.tar.bz2
jranvier-4b0b8e1439c164dda31d0acb71e6b9ac8bf1b621.zip
move armory to net-misc instead of net-p2p
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/armory/armory-0.86.ebuild35
-rw-r--r--net-misc/armory/armory-9999.ebuild34
-rw-r--r--net-misc/armory/metadata.xml8
3 files changed, 77 insertions, 0 deletions
diff --git a/net-misc/armory/armory-0.86.ebuild b/net-misc/armory/armory-0.86.ebuild
new file mode 100644
index 0000000..985f80c
--- /dev/null
+++ b/net-misc/armory/armory-0.86.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit git-2
+
+DESCRIPTION="Armory is an advanced Bitcoin client"
+HOMEPAGE="http://bitcoinarmory.com/"
+
+EGIT_REPO_URI="git://github.com/etotheipi/BitcoinArmory.git"
+EGIT_COMMIT="v0.86-beta"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+RDEPEND="net-p2p/bitcoin-qt"
+
+DEPEND="dev-python/PyQt4
+ dev-lang/swig
+ dev-python/twisted
+ x11-misc/xdg-utils"
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README
+}
+
+pkg_postinst() {
+ xdg-icon-resource install --novendor --context apps --size 64 /usr/share/armory/img/armory_icon_64x64.png armoryicon
+ xdg-icon-resource install --novendor --context apps --size 64 /usr/share/armory/img/armory_icon_64x64.png armoryofflineicon
+ xdg-icon-resource install --novendor --context apps --size 64 /usr/share/armory/img/armory_icon_green_64x64.png armorytestneticon
+}
diff --git a/net-misc/armory/armory-9999.ebuild b/net-misc/armory/armory-9999.ebuild
new file mode 100644
index 0000000..6970bf8
--- /dev/null
+++ b/net-misc/armory/armory-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit git-2
+
+DESCRIPTION="Armory is an advanced Bitcoin client"
+HOMEPAGE="http://bitcoinarmory.com/"
+
+EGIT_REPO_URI="git://github.com/etotheipi/BitcoinArmory.git"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="net-p2p/bitcoin-qt"
+
+DEPEND="dev-python/PyQt4
+ dev-lang/swig
+ dev-python/twisted
+ x11-misc/xdg-utils"
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README
+}
+
+pkg_postinst() {
+ xdg-icon-resource install --novendor --context apps --size 64 /usr/share/armory/img/armory_icon_64x64.png armoryicon
+ xdg-icon-resource install --novendor --context apps --size 64 /usr/share/armory/img/armory_icon_64x64.png armoryofflineicon
+ xdg-icon-resource install --novendor --context apps --size 64 /usr/share/armory/img/armory_icon_green_64x64.png armorytestneticon
+}
diff --git a/net-misc/armory/metadata.xml b/net-misc/armory/metadata.xml
new file mode 100644
index 0000000..e51666b
--- /dev/null
+++ b/net-misc/armory/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>justusranvier@tormail.org</email>
+ <name>Justus Ranvier</name>
+ </maintainer>
+</pkgmetadata>