summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/xmorph/xmorph-20090929.ebuild')
-rw-r--r--media-gfx/xmorph/xmorph-20090929.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-gfx/xmorph/xmorph-20090929.ebuild b/media-gfx/xmorph/xmorph-20090929.ebuild
new file mode 100644
index 0000000..340d53c
--- /dev/null
+++ b/media-gfx/xmorph/xmorph-20090929.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="Library that implements digital image warping, known as morphing, along with GUIs."
+HOMEPAGE="http://xmorph.sourceforge.net/"
+SRC_URI="http://ftp.de.debian.org/debian/pool/main/x/xmorph/xmorph_20090926.tar.gz"
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="gtk nls fftw"
+# Options I'm ignoring:
+# --with-waili --with-xmorph --with-tkmorph
+
+# --disable-gtktest \
+# --without-gtkmorph \
+
+RDEPEND="nls? ( virtual/libintl )
+ gtk? ( x11-libs/gtk+ )"
+
+DEPEND="nls? ( sys-devel/gettext )
+ gtk? ( x11-libs/gtk+ )
+ fftw? ( >=sci-libs/fftw-3 )"
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_with gtk gtkmorph) \
+ $(use_with fftw) \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+}