summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Kaiser <nikai@nikai.net>2010-07-23 13:24:18 +0200
committerNicolas Kaiser <nikai@nikai.net>2010-07-23 13:24:18 +0200
commit1cd7bc74cb04fdc693030e41a26ca93f1bf56e87 (patch)
tree9e2049a0dbcfe2bf256090f1e2383cf59ec861a4
parentvs: removed USE stencil-buffer and sdl (diff)
downloadnikai-1cd7bc74cb04fdc693030e41a26ca93f1bf56e87.tar.gz
nikai-1cd7bc74cb04fdc693030e41a26ca93f1bf56e87.tar.bz2
nikai-1cd7bc74cb04fdc693030e41a26ca93f1bf56e87.zip
vs: removed USE no-sound, added USE ffmpeg
Would be fun to be able to completely remove sound support. However, at the moment it fails to build without sound: make[1]: *** [src/aldrv/al_sound.o] Error 1 On the other hand, builds without ffmpeg. Warn if vssetup doesn't get built. Added USE descriptions to metadata.
-rw-r--r--games-simulation/vegastrike/Manifest4
-rw-r--r--games-simulation/vegastrike/metadata.xml6
-rw-r--r--games-simulation/vegastrike/vegastrike-9999.ebuild19
3 files changed, 16 insertions, 13 deletions
diff --git a/games-simulation/vegastrike/Manifest b/games-simulation/vegastrike/Manifest
index 09d5cbc..99ddd93 100644
--- a/games-simulation/vegastrike/Manifest
+++ b/games-simulation/vegastrike/Manifest
@@ -1,2 +1,2 @@
-EBUILD vegastrike-9999.ebuild 4824 RMD160 5b0400d8290e8f065e1c9ee67551e101fbef5cd1 SHA1 8117c7e77b74be95d90f995206ceac6f6fce9d9c SHA256 ba47f47a061462caa577ef8d6cc4bd3d177b984ac299328405baa79f67999817
-MISC metadata.xml 671 RMD160 6c964ae8b57056db2415e1c6f91a57ec4999eb8a SHA1 602a55543529137a42dacbbfcc4f41a79ea1d793 SHA256 ffed287b090be6ab85937d4b1f6b05285d2ae3ea8b409b4b3e60ca356e342852
+EBUILD vegastrike-9999.ebuild 4923 RMD160 3d45d717abe793487ef4aac10f51a061ffdeeb75 SHA1 464be54b68b42e1ff4fe3a269d540c886a9806d2 SHA256 c90f5294be01d8cd42b2b2900a227163b898b3c447773997c14c49eaf56d756a
+MISC metadata.xml 661 RMD160 9590d3f59a89cefc68fc8d47a51e070c8ad62355 SHA1 ef1c5ae3612fd06b27369eb7e73dbf5d79439af7 SHA256 b84cf9e11ce628e37a3778ce5f1ce28a93e803847e5fc168130d039f396c8cf9
diff --git a/games-simulation/vegastrike/metadata.xml b/games-simulation/vegastrike/metadata.xml
index e13eb2b..cc2f6aa 100644
--- a/games-simulation/vegastrike/metadata.xml
+++ b/games-simulation/vegastrike/metadata.xml
@@ -7,8 +7,8 @@
</maintainer>
<longdescription>Vega Strike is an Open Source 3D Action-Space-Sim that lets you trade, fight, and explore in a vast universe. The vegastrike branch contains the game source code.</longdescription>
<use>
- <flag name='gtk'>FIXME: Description of how USE='gtk' affects this package</flag>
- <flag name='debug'>FIXME: Description of how USE='debug' affects this package</flag>
- <flag name='no-sound'>FIXME: Check config and dependencies.</flag>
+ <flag name='gtk'>Uses <pkg>x11-libs/gtk+</pkg> for graphical configuration (vssetup).</flag>
+ <flag name='ffmpeg'>Enables support for <pkg>media-video/ffmpeg</pkg>.</flag>
+ <flag name='debug'>Enable debugging support.</flag>
</use>
</pkgmetadata>
diff --git a/games-simulation/vegastrike/vegastrike-9999.ebuild b/games-simulation/vegastrike/vegastrike-9999.ebuild
index b8836a1..f0ac9ea 100644
--- a/games-simulation/vegastrike/vegastrike-9999.ebuild
+++ b/games-simulation/vegastrike/vegastrike-9999.ebuild
@@ -16,7 +16,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
# FIXME: check configure options
-IUSE="gtk no-sound debug"
+IUSE="ffmpeg gtk debug"
# FIXME: check dependencies
RDEPEND="
@@ -26,9 +26,10 @@ RDEPEND="
dev-libs/expat
media-libs/openal
media-libs/libsdl
- !no-sound? ( media-libs/libvorbis
- media-libs/libogg
- media-libs/sdl-mixer )
+ media-libs/libvorbis
+ media-libs/libogg
+ media-libs/sdl-mixer
+ ffmpeg? ( media-video/ffmpeg )
virtual/glut
virtual/glu
gtk? ( x11-libs/gtk+ )
@@ -109,8 +110,11 @@ src_compile() {
conf_opts="${conf_opts} --disable-gtk"
fi
+ if ! use ffmpeg; then
+ conf_opts="${conf_opts} --disable-ffmpeg"
+ fi
+
CONFIGURE_OPTIONS="
- $(use_enable !no-sound sound)
${conf_opts}"
egamesconf $CONFIGURE_OPTIONS \
@@ -152,9 +156,8 @@ EOF
dogamesbin vegastrike/mesher \
|| die "Creation of mesher failed"
- if use gtk; then
- newgamesbin vegastrike/vssetup vssetup || die "newgamesbin failed"
- fi
+ newgamesbin vegastrike/vssetup vssetup \
+ || ewarn "vssetup was not built. You will have to manually edit ~/.vegastrike/vegastrike.config."
make_desktop_entry "vegastrike" "Vegastrike" "${GAMES_DATADIR}/${PN}/data/vegastrike.xpm"