summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/podman-compose/podman-compose-1.0.6.ebuild')
-rw-r--r--app-containers/podman-compose/podman-compose-1.0.6.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-containers/podman-compose/podman-compose-1.0.6.ebuild b/app-containers/podman-compose/podman-compose-1.0.6.ebuild
new file mode 100644
index 0000000..6b09f29
--- /dev/null
+++ b/app-containers/podman-compose/podman-compose-1.0.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+inherit distutils-r1
+
+DESCRIPTION="a script to run docker-compose.yml using podman"
+HOMEPAGE="https://github.com/containers/podman-compose"
+SRC_URI="https://github.com/containers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+#S="${WORKDIR}/${PN}-release-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~arm64"
+
+BDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+"
+RDEPEND="${BDEPEND}"
+
+distutils_enable_tests pytest