summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/curlie/curlie-1.6.0.ebuild')
-rw-r--r--net-misc/curlie/curlie-1.6.0.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/net-misc/curlie/curlie-1.6.0.ebuild b/net-misc/curlie/curlie-1.6.0.ebuild
deleted file mode 100644
index 2b714c8..0000000
--- a/net-misc/curlie/curlie-1.6.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-EGO_PN="github.com/rs/${PN}"
-EGO_VENDOR=(
- "github.com/akamensky/argparse 99676ba18cd5"
- "github.com/jessevdk/go-flags v1.4.0"
- "golang.org/x/crypto 159ae71589f3 github.com/golang/crypto"
- "golang.org/x/sys 33540a1f6037 github.com/golang/sys"
-)
-
-inherit golang-build golang-vcs-snapshot
-
-DESCRIPTION="The power of curl, the ease of use of httpie, written in GoLang"
-ARCHIVE_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- ${EGO_VENDOR_URI}"
-SRC_URI="${ARCHIVE_URI}"
-RESTRICT="mirror"
-
-LICENSE="MIT"
-SLOT="0/${PVR}"
-KEYWORDS="~amd64 ~x86 ~arm"
-IUSE="+pie"
-
-src_compile() {
- # -buildmode=pie forces external linking mode, even CGO_ENABLED=0
- # https://github.com/golang/go/issues/18968
- use pie && local build_pie="-buildmode=pie"
-
- local build_flags="$( echo ${EGO_BUILD_FLAGS} ) $( echo ${build_pie} )"
-
- set -- env GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
- GOCACHE="${T}/go-cache" \
- CGO_ENABLED=0 \
- GO111MODULE=off \
- go install -v -work -x ${build_flags} ${EGO_PN}
- echo "$@"
- "$@" || die
-}
-
-src_install() {
- dobin bin/*
-}