summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Solano Gómez <gentoo@sattvik.com>2011-07-18 18:57:38 -0500
committerDaniel Solano Gómez <gentoo@sattvik.com>2011-07-18 18:57:38 -0500
commit7a5a9a474e6ff256619311eb465471866edc9221 (patch)
tree1f82b2bec9ced1e4d2711bb1046ea27433ab893a /dev-util
parentAdd new dblatex ebuild (diff)
downloadsattvik-7a5a9a474e6ff256619311eb465471866edc9221.tar.gz
sattvik-7a5a9a474e6ff256619311eb465471866edc9221.tar.bz2
sattvik-7a5a9a474e6ff256619311eb465471866edc9221.zip
Add source-highlight-3.1.4
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/source-highlight/Manifest3
-rw-r--r--dev-util/source-highlight/metadata.xml9
-rw-r--r--dev-util/source-highlight/source-highlight-3.1.4.ebuild44
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-util/source-highlight/Manifest b/dev-util/source-highlight/Manifest
new file mode 100644
index 0000000..065ecd6
--- /dev/null
+++ b/dev-util/source-highlight/Manifest
@@ -0,0 +1,3 @@
+DIST source-highlight-3.1.4.tar.gz 1520307 RMD160 36be866d1fe97af2867562ba48256a36e1b18619 SHA1 a9398f59200223058560f3b6b560b2ad58956e0e SHA256 acb3f9119b4873e2b4da019cad1868b0b9a80aca66466a5268f48aaead02a3c9
+EBUILD source-highlight-3.1.4.ebuild 1481 RMD160 223221443a5ef63be5b3d11a9b7aa5c953d349c2 SHA1 c46925208af71a280dc60b0f3c36cfc97aa457f8 SHA256 8da0e526d088a545e522de4b7b8ca420eaac52f86f1afdd2a6d122f8e94a1881
+MISC metadata.xml 258 RMD160 f41059a7f29a2b5493ad80203a94a9a519bc5dcf SHA1 ebaf62e3133e26efd7eaac694e53d0398c2bc0de SHA256 79e17085ca01237995cedc73430ae1c4bbd3092968cffe18ea41237f7a2c1939
diff --git a/dev-util/source-highlight/metadata.xml b/dev-util/source-highlight/metadata.xml
new file mode 100644
index 0000000..78170ac
--- /dev/null
+++ b/dev-util/source-highlight/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-util/source-highlight/source-highlight-3.1.4.ebuild b/dev-util/source-highlight/source-highlight-3.1.4.ebuild
new file mode 100644
index 0000000..432ab2c
--- /dev/null
+++ b/dev-util/source-highlight/source-highlight-3.1.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/source-highlight/source-highlight-3.1.ebuild,v 1.9 2011/04/10 03:07:43 abcd Exp $
+
+EAPI="3"
+
+inherit bash-completion versionator
+
+DESCRIPTION="Generate highlighted source code as an (x)html document"
+HOMEPAGE="http://www.gnu.org/software/src-highlite/source-highlight.html"
+SRC_URI="mirror://gnu/src-highlite/${P}.tar.gz"
+LICENSE="GPL-3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+SLOT="0"
+IUSE="bash-completion doc"
+
+DEPEND=">=dev-libs/boost-1.35.0-r5
+ dev-util/ctags"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.35.0-r5")"
+ BOOST_VER="$(replace_all_version_separators _ $(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}"))"
+
+ sed -i \
+ -e "s|ac_boost_path_tmp/include|ac_boost_path_tmp/include/boost-${BOOST_VER}|" \
+ configure || die "sed failed"
+
+ econf \
+ --with-boost-regex="boost_regex-mt-${BOOST_VER}" \
+ --without-bash-completion
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ use bash-completion && dobashcompletion source-highlight-bash-completion
+
+ # That's not how we want it
+ rm -fr "${ED}/usr/share"/{aclocal,doc}
+ dodoc AUTHORS ChangeLog CREDITS NEWS README THANKS TODO.txt
+
+ use doc && dohtml -A java doc/*.{html,css,java}
+}