summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/cli11/cli11-2.2.0.ebuild')
-rw-r--r--dev-cpp/cli11/cli11-2.2.0.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-cpp/cli11/cli11-2.2.0.ebuild b/dev-cpp/cli11/cli11-2.2.0.ebuild
deleted file mode 100644
index d5c40fb..0000000
--- a/dev-cpp/cli11/cli11-2.2.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DOCS_BUILDER="doxygen"
-DOCS_DIR="docs"
-inherit cmake docs
-
-CATCH_PV=2.13.6
-DESCRIPTION="Command line parser for C++11"
-HOMEPAGE="https://github.com/CLIUtils/CLI11 https://cliutils.github.io/CLI11/book/"
-SRC_URI="https://github.com/CLIUtils/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/CLI11-${PV}"
-
-LICENSE="BSD"
-SLOT="0/2"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? (
- dev-cpp/catch:0
- dev-libs/boost
-)"
-
-DOCS=( README.md CHANGELOG.md )
-
-src_configure() {
- local mycmakeargs=(
- -DCLI11_BUILD_DOCS=OFF # handled by docs.eclass
- -DCLI11_BUILD_TESTS=$(usex test)
- )
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- docs_compile
-}