summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortocaro <tocaro@thocar.org>2014-04-05 23:28:43 +0200
committertocaro <tocaro@thocar.org>2014-04-05 23:28:43 +0200
commitf848b44c50a342b6c47bbf273b92249c159278c8 (patch)
treed3b4a7066bdc19b0ad8e5d1ebd164f24f6f65df1
parentok (diff)
downloadtocaro-f848b44c50a342b6c47bbf273b92249c159278c8.tar.gz
tocaro-f848b44c50a342b6c47bbf273b92249c159278c8.tar.bz2
tocaro-f848b44c50a342b6c47bbf273b92249c159278c8.zip
new ebuild to watch that rdiff-backup directory is healthy
-rw-r--r--app-backup/tho-rdiffwatch/ChangeLog8
-rw-r--r--app-backup/tho-rdiffwatch/Manifest4
-rw-r--r--app-backup/tho-rdiffwatch/metadata.xml10
-rw-r--r--app-backup/tho-rdiffwatch/tho-rdiffwatch-0.1.ebuild23
4 files changed, 45 insertions, 0 deletions
diff --git a/app-backup/tho-rdiffwatch/ChangeLog b/app-backup/tho-rdiffwatch/ChangeLog
new file mode 100644
index 0000000..a2d37b2
--- /dev/null
+++ b/app-backup/tho-rdiffwatch/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for x11-misc/tho-rsync
+# Copyright 2013-2014 Thomas Carrie; Distributed under the GPL v2
+# $Header: $
+
+*tho-rdiffwatch-0.1 (05 Apr 2014)
+
+ 05 Apr 2014; Thomas Carrie <tocaro@thocar.org> :
+ Initial import.
diff --git a/app-backup/tho-rdiffwatch/Manifest b/app-backup/tho-rdiffwatch/Manifest
new file mode 100644
index 0000000..0fd163e
--- /dev/null
+++ b/app-backup/tho-rdiffwatch/Manifest
@@ -0,0 +1,4 @@
+DIST tho-rdiffwatch-0.1.tar.gz 1587 SHA256 7f048ae94614927043fdfc934fc223347d5c47ec8a25e21d35132f9d28fcf5a1 SHA512 ff53c1a38851f13eabef16bda6e078416254bad273da48b021ee2759f6a59f704640001d3a6979ac43adb846c13ddb7e838b04fee03dce1ef132d30eb3da832e WHIRLPOOL eb27940b496a0a917395d9da0fac99f5c341a5fe1aedaf82f1c42f06e97df87e5a205855d7b2aa0e12121404137d272e174b328a7475f084b21a01fc48efaa52
+EBUILD tho-rdiffwatch-0.1.ebuild 589 SHA256 3976e9a4bbba21f9f8438307417c94b10fa5b40fa710e89104b2b35a4455a13b SHA512 a75cbd61dddd17b0ae6ae2eb71d6e5c26be38fdc912ff2b7b1848a7db690570d9abfe2df7029b791672380d239c8f03d080dc230a20a64230823f1745e8ef80d WHIRLPOOL 12a15ad32516e1dd9887719bc61136d95fb0cfc3b2c843a5dd75e8d533252982bab1f772676a7cd876b2ec0c5f48fafdb0d98f2ff07d31feacdceb2bcf12a954
+MISC ChangeLog 219 SHA256 ec6f5ea6286ddb694c9a70607c03334418f22647d3f2979b1b6ecc3431e8b6f5 SHA512 c56603bb849d4aada43cc8a7a765a861a354b4b58ee6dcd5463bfc54e0aad554a9a68d2a4fb8a0e9c4f3a3cb3306e324fee2a8d4f8db11ba13bafb03ba421db2 WHIRLPOOL 5eafc500bbf8e7368c67d2afd878c95ce2580e366ef6c68143196a38f67586bc45699e1bd97c31c78d6f7d43911bd05259e4cc976fcd0f617c5f3d08be81c2e3
+MISC metadata.xml 475 SHA256 385fd9023cf35f214f91c664863a06079c78152af28c5228afb07b3ce5a9a152 SHA512 a757306fe851d8180703206bf9d1352bcdadde25b1819a46c558dc9aa6563b078afa5823e2044bc11c9299eb941eb34fc44bece9508208052be2b458caa1c856 WHIRLPOOL 2aeaf66ae90e315e64bb61d1218a5ecfce51fac2f43f68df1eb81005ee315faed781838304640311338dd5102e09d2f1c905983c587e6cd62fb91d0781a0ae47
diff --git a/app-backup/tho-rdiffwatch/metadata.xml b/app-backup/tho-rdiffwatch/metadata.xml
new file mode 100644
index 0000000..efed7c0
--- /dev/null
+++ b/app-backup/tho-rdiffwatch/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- http://devmanual.gentoo.org/ebuild-writing/misc-files/metadata/ -->
+ <!-- herd>not maintained by a herd</herd-->
+ <maintainer>
+ <email>tocaro@thocar.org</email>
+ </maintainer>
+ <longdescription>If you use rdiff-backup, you probably would like to have a script to put in the crontab to monitor your rdiff backup</longdescription>
+</pkgmetadata>
diff --git a/app-backup/tho-rdiffwatch/tho-rdiffwatch-0.1.ebuild b/app-backup/tho-rdiffwatch/tho-rdiffwatch-0.1.ebuild
new file mode 100644
index 0000000..7470ce7
--- /dev/null
+++ b/app-backup/tho-rdiffwatch/tho-rdiffwatch-0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2013-2014 Thomas Carrie
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="If you use rdiff-backup, you probably would like to have a script to put in the crontab to monitor your rdiff backup"
+HOMEPAGE="http://thocar.org/tarballs/"
+SRC_URI="http://thocar.org/tarballs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm x86"
+IUSE=""
+DEPEND=""
+RDEPEND=">=app-backup/rdiff-backup-1.3.3"
+
+src_install() {
+ # http://devmanual.gentoo.org/function-reference/install-functions/
+ dobin thordiffwatch
+}