summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Phillips <write2david@gmail.com>2012-08-01 01:36:21 -0500
committerDavid Phillips <write2david@gmail.com>2012-08-01 01:36:21 -0500
commita41f49de9e71096cfb3c2f876c108ec47caf5dbf (patch)
tree864ae3f323a8877f5c59d6615d8fbb6c26db7da6
parentNew easystroke-0.5.5.1.ebuild WRT 253783 (diff)
downloadwrite2David-a41f49de9e71096cfb3c2f876c108ec47caf5dbf.tar.gz
write2David-a41f49de9e71096cfb3c2f876c108ec47caf5dbf.tar.bz2
write2David-a41f49de9e71096cfb3c2f876c108ec47caf5dbf.zip
Add -r2 for cairo-dock-plugins
-rw-r--r--x11-plugins/cairo-dock-plugins/Manifest3
-rw-r--r--x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r1.ebuild2
-rw-r--r--x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r2.ebuild125
3 files changed, 128 insertions, 2 deletions
diff --git a/x11-plugins/cairo-dock-plugins/Manifest b/x11-plugins/cairo-dock-plugins/Manifest
index 9612631..27979a6 100644
--- a/x11-plugins/cairo-dock-plugins/Manifest
+++ b/x11-plugins/cairo-dock-plugins/Manifest
@@ -1,4 +1,5 @@
-EBUILD cairo-dock-plugins-9999-r1.ebuild 3991 RMD160 692d367c857d1026d74398e517a6c58995afbaaf SHA1 d59bdfb343aaacb478f689a3073ebe4ed7a9f612 SHA256 664c79e9585a97806e88454d4975f9cf23ef45538c6097d5edcaa45e7ee6d9df
+EBUILD cairo-dock-plugins-9999-r1.ebuild 3994 RMD160 6c6d2bf73d959f65abcaf73e0856fe2f421b338e SHA1 566d37d05394a5c61446eeebd2090feee15d41ec SHA256 1bcfa4053be54eaed039c3c81d827273346a3173ff477ebf06c29a4c72a75ff0
+EBUILD cairo-dock-plugins-9999-r2.ebuild 4128 RMD160 e0476b8f19dbe511962f018fc19ec7a9c6705135 SHA1 306547bd2e08c47af30808b9cbf4f78dd4608ee9 SHA256 48e2303d2acc29022098f03e017717e7511566dfcabe8d4f9ae618d7be11a762
EBUILD cairo-dock-plugins-9999.ebuild 2916 RMD160 261557b98a558304fb6a04c62fe124b6f2c9ccca SHA1 652f06bd27049676f0b56508c2907105b13c2f3b SHA256 fa91a8cb095df1a25a4362065ad1aea0367656da1e439c1f0e45da35bdf0b3d4
MISC ChangeLog 240 RMD160 55af20059609afd5f2f7c6587a398a8771ad3b97 SHA1 954131dc27940452045dd947d865332f92420cbe SHA256 ffd103359939888e5c0463fda3245d4e54b55fdcc16782e5e83f14fbaaa31efd
MISC metadata.xml 276 RMD160 0c0c308f1457fd6b3524628543f0452d1dc39197 SHA1 e296372ecbbb13ad02430b5d323ea54c7fc5f086 SHA256 cc9796aef23ea695fd2cc82f8c763e3463f4ddcc335f716740ef0d568f4ca6e9
diff --git a/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r1.ebuild b/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r1.ebuild
index 7abbbbb..01b2793 100644
--- a/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r1.ebuild
+++ b/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r1.ebuild
@@ -91,7 +91,7 @@ src_configure() {
# Weird, cairo-dock installs files are under /usr/usr not /usr
- export PKG_CONFIG_PATH="${PKG_CONFIG_PATH:+${PKG_CONFIG_PATH}:}/usr/usr/lib/pkgconfig"
+ export PKG_CONFIG_PATH="${PKG_CONFIG_PATH:+${PKG_CONFIG_PATH}:}/usr/usr/lib/pkgconfig"
# Check the PKG_CONFIG_PATH value to make sure we're good...
echo "The pkg_config variable is: ${PKG_CONFIG_PATH}"
diff --git a/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r2.ebuild b/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r2.ebuild
new file mode 100644
index 0000000..37b98d5
--- /dev/null
+++ b/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r2.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+# Launchpad repository where "cairo-dock-plugins" lives:
+EBZR_REPO_URI="lp:cairo-dock-plug-ins"
+
+# You can specify a certain revision from the repository here.
+# Or comment it out to choose the latest ("live") revision.
+#EBZR_REVISION="2242"
+
+inherit cmake-utils bzr
+
+DESCRIPTION="Official plugins for cairo-dock"
+HOMEPAGE="https://launchpad.net/cairo-dock-plug-ins/"
+SRC_URI=""
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+
+# The next line has been stripped down somewhat from a longer version
+# used in the ebuilds of other overlays. For more info, see:
+# https://bugs.launchpad.net/cairo-dock-plug-ins/+bug/922981/comments/8
+IUSE="alsa exif gmenu terminal vala webkit xfce xgamma xklavier"
+
+# Installation instructions (from BZR source) and dependencies are listed here:
+# http://glx-dock.org/ww_page.php?p=From%20BZR&lang=en
+
+RDEPEND="
+ ~x11-misc/cairo-dock-${PV}
+ x11-libs/cairo
+ gnome-base/librsvg
+ dev-libs/libxml2
+ alsa? ( media-libs/alsa-lib )
+ exif? ( media-libs/libexif )
+ gmenu? ( gnome-base/gnome-menus )
+ terminal? ( x11-libs/vte )
+ webkit? ( >=net-libs/webkit-gtk-1.0 )
+ xfce? ( xfce-base/thunar )
+ xgamma? ( x11-libs/libXxf86vm )
+ xklavier? ( x11-libs/libxklavier )
+ vala? ( dev-lang/vala:0.12 )
+"
+
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ dev-util/pkgconfig
+ dev-libs/libdbusmenu:3[gtk]
+"
+
+pkg_setup()
+{
+ ewarn ""
+ ewarn ""
+ ewarn "THIS IS A LIVE EBUILD, NOT AN OFFICIAL RELEASE."
+ ewarn " Thus, it may FAIL to build properly."
+ ewarn " Please do NOT report bugs to Gentoo's bugzilla."
+ ewarn " Instead, report all bugs to write2david@gmail.com"
+ ewarn ""
+ ewarn ""
+}
+
+src_prepare() {
+ bzr_src_prepare
+}
+
+# ==== These lines are from someone else's ebuild, with my notes...
+
+# Can't find out what the following line does (no Gentoo documentation on it?) and it seems to find the makefile and compile fine without it, so commenting it out.
+#MAKE_IN_SOURCE_BUILD=true
+
+# Actually, it looks like it is supposed to be CMAKE_IN_SOURCE_BUILD
+# http://devmanual.gentoo.org/eclass-reference/cmake-utils.eclass/index.html
+# But still not needed, so it is still commented out.
+#CMAKE_IN_SOURCE_BUILD=true
+
+
+src_configure() {
+
+ # Next line added because of the same issues/solution as reported on...
+ # ... http://glx-dock.org/bg_topic.php?t=5733
+
+ # Where to put this variable declaration was inspired from...
+ # http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/x11-libs/cairo/cairo-0.1.18.ebuild?hideattic=0&view=markup
+ # However, adding this to "configure" not "compile" because the error show
+ # up during configure stage.
+
+ # Weird, cairo-dock installs files are under /usr/usr not /usr
+
+ export PKG_CONFIG_PATH="${PKG_CONFIG_PATH}:/usr/usr/lib/pkgconfig:/usr/usr/lib6464/pkgconfig"
+
+ # Check the PKG_CONFIG_PATH value to make sure we're good...
+ echo "The pkg_config variable is: ${PKG_CONFIG_PATH}"
+
+
+ # Next line added because of the same issues/solutions reported on...
+ # ... # https://bugs.launchpad.net/cairo-dock-plug-ins/+bug/922981
+ #
+ # With a solution inspired on...
+ # http://code.google.com/p/rion-overlay/source/browse/x11-misc/cairo-dock-plugins/cairo-dock-plugins-2.3.9999.ebuild?spec=svn71d4acbbb8c297b818ff886fb5dd434a6f54c377&r=71d4acbbb8c297b818ff886fb5dd434a6f54c377
+
+ # Some more info... http://www.cmake.org/Wiki/CMake_Useful_Variables
+ mycmakeargs="${mycmakeargs} -DROOT_PREFIX=${D} -DCMAKE_INSTALL_PREFIX=/usr"
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ ewarn ""
+ ewarn ""
+ ewarn "THIS IS A LIVE EBUILD, NOT AN OFFICIAL RELEASE."
+ ewarn " Thus, it may FAIL to run properly."
+ ewarn " Please do NOT report bugs to Gentoo's bugzilla."
+ ewarn " Instead, report all bugs to write2david@gmail.com"
+ ewarn ""
+ ewarn ""
+ # Dealing with the weird issue of cairo-dock installing under /usr/usr
+ # Without this next line, cairo-dock won't start
+ # Also, a report of weird behavior of installing under "lib6464"
+ ln -s /usr/usr/lib/libgldi.so.3 /usr/lib/libgldi.so.3
+ ln -s /usr/usr/lib6464/libgldi.so.3 /usr/lib64/libgldi.so.3
+}