summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'pentoo/pentoo-installer/pentoo-installer-0.8.1.ebuild')
-rw-r--r--pentoo/pentoo-installer/pentoo-installer-0.8.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/pentoo/pentoo-installer/pentoo-installer-0.8.1.ebuild b/pentoo/pentoo-installer/pentoo-installer-0.8.1.ebuild
new file mode 100644
index 0000000..dbe64cb
--- /dev/null
+++ b/pentoo/pentoo-installer/pentoo-installer-0.8.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit subversion
+
+DESCRIPTION="Installer for pentoo"
+HOMEPAGE="https://code.google.com/p/pentoo/"
+ESVN_REPO_URI="https://${PN}.googlecode.com/svn/tags/v${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+
+DEPEND="app-arch/xz-utils"
+RDEPEND="dev-util/dialog
+ X? ( x11-misc/xdialog )
+ || ( sys-boot/grub:0
+ sys-boot/grub-static:0 )
+ sys-boot/grub:2
+ sys-fs/squashfs-tools
+ net-misc/rsync"
+
+src_install() {
+ dodir /usr/
+ cp -R "${S}"/* "${ED}"/usr/ || die "Copy files failed"
+ exeinto /root/Desktop/
+ doexe share/applications/pentoo-installer.desktop
+}