summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-08-08 04:35:53 +0000
committerBrian Evans <grknight@gentoo.org>2015-08-08 04:35:53 +0000
commit4c1755e5b96b4f37482b23bb751a233cf7d96bea (patch)
treeaeb9871fbc81be4384cd7bbe984ad76f73265fb6 /dev-db
parentVersion bump for 10.0 series (diff)
downloadgentoo-2-4c1755e5b96b4f37482b23bb751a233cf7d96bea.tar.gz
gentoo-2-4c1755e5b96b4f37482b23bb751a233cf7d96bea.tar.bz2
gentoo-2-4c1755e5b96b4f37482b23bb751a233cf7d96bea.zip
Version bump for 5.5 series; Drop old 5.5s
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xD1F781EFF9F4A3B6)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mariadb/ChangeLog8
-rw-r--r--dev-db/mariadb/mariadb-5.5.44.ebuild118
-rw-r--r--dev-db/mariadb/mariadb-5.5.45.ebuild (renamed from dev-db/mariadb/mariadb-5.5.43-r1.ebuild)7
3 files changed, 13 insertions, 120 deletions
diff --git a/dev-db/mariadb/ChangeLog b/dev-db/mariadb/ChangeLog
index ce51eead9a0d..d2816b3d5a02 100644
--- a/dev-db/mariadb/ChangeLog
+++ b/dev-db/mariadb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/mariadb
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mariadb/ChangeLog,v 1.117 2015/08/08 03:41:14 grknight Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mariadb/ChangeLog,v 1.118 2015/08/08 04:35:53 grknight Exp $
+
+*mariadb-5.5.45 (08 Aug 2015)
+
+ 08 Aug 2015; Brian Evans <grknight@gentoo.org> +mariadb-5.5.45.ebuild,
+ -mariadb-5.5.43-r1.ebuild, -mariadb-5.5.44.ebuild:
+ Version bump for 5.5 series; Drop old 5.5s
*mariadb-10.0.21-r1 (08 Aug 2015)
*mariadb-10.0.21 (08 Aug 2015)
diff --git a/dev-db/mariadb/mariadb-5.5.44.ebuild b/dev-db/mariadb/mariadb-5.5.44.ebuild
deleted file mode 100644
index 5cf1ddf50a6d..000000000000
--- a/dev-db/mariadb/mariadb-5.5.44.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mariadb/mariadb-5.5.44.ebuild,v 1.1 2015/06/20 01:46:49 grknight Exp $
-
-EAPI="5"
-MY_EXTRAS_VER="20150509-1847Z"
-
-# Build system
-BUILD="cmake"
-
-inherit toolchain-funcs mysql-v2
-# only to make repoman happy. it is really set in the eclass
-IUSE="$IUSE"
-
-# REMEMBER: also update eclass/mysql*.eclass before committing!
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-
-# When MY_EXTRAS is bumped, the index should be revised to exclude these.
-EPATCH_EXCLUDE=''
-
-DEPEND="|| ( >=sys-devel/gcc-3.4.6 >=sys-devel/gcc-apple-4.0 )"
-RDEPEND="${RDEPEND}"
-
-# Please do not add a naive src_unpack to this ebuild
-# If you want to add a single patch, copy the ebuild to an overlay
-# and create your own mysql-extras tarball, looking at 000_index.txt
-
-# Official test instructions:
-# USE='embedded extraengine perl ssl static-libs community' \
-# FEATURES='test userpriv -usersandbox' \
-# ebuild mariadb-X.X.XX.ebuild \
-# digest clean package
-src_test() {
-
- local TESTDIR="${BUILD_DIR}/mysql-test"
- local retstatus_unit
- local retstatus_tests
-
- # Bug #213475 - MySQL _will_ object strenously if your machine is named
- # localhost. Also causes weird failures.
- [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
-
- if ! use "minimal" ; then
-
- if [[ $UID -eq 0 ]]; then
- die "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
- fi
- has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
-
- einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
- addpredict /this-dir-does-not-exist/t9.MYI
-
- # Run CTest (test-units)
- cmake-utils_src_test
- retstatus_unit=$?
- [[ $retstatus_unit -eq 0 ]] || eerror "test-unit failed"
-
- # Ensure that parallel runs don't die
- export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
- # Enable parallel testing, auto will try to detect number of cores
- # You may set this by hand.
- # The default maximum is 8 unless MTR_MAX_PARALLEL is increased
- export MTR_PARALLEL="${MTR_PARALLEL:-auto}"
-
- # create directories because mysqladmin might right out of order
- mkdir -p "${T}"/var-tests{,/log}
-
- # create symlink for the tests to find the replace util
- ln -s "${BUILD_DIR}/extra/replace" "${BUILD_DIR}/client/"
-
- # These are failing in MariaDB 5.5 for now and are believed to be
- # false positives:
- #
- # main.information_schema, binlog.binlog_statement_insert_delayed,
- # main.mysqld--help, funcs_1.is_triggers, funcs_1.is_tables_mysql,
- # funcs_1.is_columns_mysql
- # fails due to USE=-latin1 / utf8 default
- #
- # main.mysql_client_test, main.mysql_client_test_nonblock:
- # segfaults at random under Portage only, suspect resource limits.
- #
-
- for t in main.mysql_client_test main.mysql_client_test_nonblock \
- binlog.binlog_statement_insert_delayed main.information_schema \
- main.mysqld--help \
- funcs_1.is_triggers funcs_1.is_tables_mysql funcs_1.is_columns_mysql ; do
- mysql-v2_disable_test "$t" "False positives in Gentoo"
- done
-
- # Run mysql tests
- pushd "${TESTDIR}"
-
- # run mysql-test tests
- perl mysql-test-run.pl --force --vardir="${T}/var-tests" \
- --testcase-timeout=30
- retstatus_tests=$?
- [[ $retstatus_tests -eq 0 ]] || eerror "tests failed"
- has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
-
- popd
-
- # Cleanup is important for these testcases.
- pkill -9 -f "${S}/ndb" 2>/dev/null
- pkill -9 -f "${S}/sql" 2>/dev/null
-
- failures=""
- [[ $retstatus_unit -eq 0 ]] || failures="${failures} test-unit"
- [[ $retstatus_tests -eq 0 ]] || failures="${failures} tests"
- has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
-
- [[ -z "$failures" ]] || die "Test failures: $failures"
- einfo "Tests successfully completed"
-
- else
-
- einfo "Skipping server tests due to minimal build."
- fi
-}
diff --git a/dev-db/mariadb/mariadb-5.5.43-r1.ebuild b/dev-db/mariadb/mariadb-5.5.45.ebuild
index 2b77a6361084..120d64353914 100644
--- a/dev-db/mariadb/mariadb-5.5.43-r1.ebuild
+++ b/dev-db/mariadb/mariadb-5.5.45.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mariadb/mariadb-5.5.43-r1.ebuild,v 1.1 2015/05/09 18:53:27 grknight Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mariadb/mariadb-5.5.45.ebuild,v 1.1 2015/08/08 04:35:53 grknight Exp $
EAPI="5"
MY_EXTRAS_VER="20150509-1847Z"
@@ -79,10 +79,15 @@ src_test() {
# main.mysql_client_test, main.mysql_client_test_nonblock:
# segfaults at random under Portage only, suspect resource limits.
#
+ # archive.mysqlhotcopy_archive main.mysqlhotcopy_myisam
+ # fails due to bad cleanup of previous tests when run in parallel
+ # The tool is deprecated anyway
+ # Bug 532288
for t in main.mysql_client_test main.mysql_client_test_nonblock \
binlog.binlog_statement_insert_delayed main.information_schema \
main.mysqld--help \
+ archive.mysqlhotcopy_archive main.mysqlhotcopy_myisam \
funcs_1.is_triggers funcs_1.is_tables_mysql funcs_1.is_columns_mysql ; do
mysql-v2_disable_test "$t" "False positives in Gentoo"
done