summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-07-04 15:38:52 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-07-04 15:38:52 +0000
commit23df6335c8d5dd3e5f8e0fbc1fe4de6febfc6633 (patch)
treebbbf4b2030dab1b419ea36603ab08e9c5f2db68b /dev-tex
parentStable on ppc and ppc64. Bug #552618. (diff)
downloadgentoo-2-23df6335c8d5dd3e5f8e0fbc1fe4de6febfc6633.tar.gz
gentoo-2-23df6335c8d5dd3e5f8e0fbc1fe4de6febfc6633.tar.bz2
gentoo-2-23df6335c8d5dd3e5f8e0fbc1fe4de6febfc6633.zip
Version bump. Fixes bug #547466.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/biber/ChangeLog8
-rw-r--r--dev-tex/biber/biber-2.1.ebuild74
-rw-r--r--dev-tex/biber/files/biber-2.1-drop-mozilla-ca.patch197
3 files changed, 278 insertions, 1 deletions
diff --git a/dev-tex/biber/ChangeLog b/dev-tex/biber/ChangeLog
index 6166457372d8..747ddfd8031f 100644
--- a/dev-tex/biber/ChangeLog
+++ b/dev-tex/biber/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tex/biber
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/biber/ChangeLog,v 1.9 2015/06/13 19:44:08 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/biber/ChangeLog,v 1.10 2015/07/04 15:38:52 mrueg Exp $
+
+*biber-2.1 (04 Jul 2015)
+
+ 04 Jul 2015; Manuel Rüger <mrueg@gentoo.org> +biber-2.1.ebuild,
+ +files/biber-2.1-drop-mozilla-ca.patch:
+ Version bump. Fixes bug #547466.
13 Jun 2015; Andreas K. Huettel <dilfridge@gentoo.org> biber-1.9.ebuild:
Module::Build is no longer part of core Perl and has been moved to dev-perl
diff --git a/dev-tex/biber/biber-2.1.ebuild b/dev-tex/biber/biber-2.1.ebuild
new file mode 100644
index 000000000000..1448e379ab87
--- /dev/null
+++ b/dev-tex/biber/biber-2.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/biber/biber-2.1.ebuild,v 1.1 2015/07/04 15:38:52 mrueg Exp $
+
+EAPI=5
+
+inherit eutils perl-module
+
+MY_PN=biblatex-${PN}
+
+DESCRIPTION="A BibTeX replacement for users of biblatex"
+HOMEPAGE="http://biblatex-biber.sourceforge.net/ https://github.com/plk/biber/"
+SRC_URI="https://github.com/plk/biber/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Artistic-2 GPL-1 GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+RDEPEND=">=dev-lang/perl-5.16
+ dev-perl/autovivification
+ dev-perl/Business-ISBN
+ dev-perl/Business-ISMN
+ dev-perl/Business-ISSN
+ dev-perl/Data-Compare
+ dev-perl/Data-Dump
+ dev-perl/Date-Simple
+ dev-perl/Encode-EUCJPASCII
+ dev-perl/Encode-HanExtra
+ dev-perl/Encode-JIS2K
+ dev-perl/File-Slurp-Unicode
+ dev-perl/IPC-Run3
+ dev-perl/libwww-perl[ssl]
+ dev-perl/List-AllUtils
+ >=dev-perl/List-MoreUtils-0.408.0
+ dev-perl/Log-Log4perl
+ dev-perl/LWP-Protocol-https
+ dev-perl/regexp-common
+ dev-perl/Readonly
+ dev-perl/Readonly-XS
+ dev-perl/Text-Roman
+ >=dev-perl/Text-BibTeX-0.700.0
+ dev-perl/URI
+ dev-perl/Unicode-LineBreak
+ dev-perl/Unicode-Normalize
+ dev-perl/XML-LibXML-Simple
+ dev-perl/XML-LibXSLT
+ dev-perl/XML-SAX-Base
+ dev-perl/XML-Writer
+ >=dev-tex/biblatex-3.0
+ virtual/perl-IPC-Cmd
+ >=virtual/perl-Unicode-Collate-1.120.0"
+DEPEND="${RDEPEND}
+ dev-perl/Config-AutoConf
+ dev-perl/Module-Build
+ test? ( dev-perl/File-Which
+ dev-perl/Test-Differences
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage )"
+
+SRC_TEST="parallel"
+
+src_prepare(){
+ epatch "${FILESDIR}"/${P}-drop-mozilla-ca.patch
+}
+
+src_install(){
+ perl-module_src_install
+ use doc && dodoc -r doc/*
+}
+
+src_test() {
+ BIBER_SKIP_DEV_TESTS=1 perl-module_src_test
+}
diff --git a/dev-tex/biber/files/biber-2.1-drop-mozilla-ca.patch b/dev-tex/biber/files/biber-2.1-drop-mozilla-ca.patch
new file mode 100644
index 000000000000..beaf08356665
--- /dev/null
+++ b/dev-tex/biber/files/biber-2.1-drop-mozilla-ca.patch
@@ -0,0 +1,197 @@
+From 29a48e5da01acb1f5f35e3a47b04ec4db42e50b9 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Manuel=20R=C3=BCger?= <manuel@rueg.eu>
+Date: Sun, 31 May 2015 00:34:11 +0200
+Subject: [PATCH] Remove Mozilla::CA dependency.
+
+
+diff --git a/Build.PL b/Build.PL
+index 841af36..b43b5fe 100644
+--- a/Build.PL
++++ b/Build.PL
+@@ -53,7 +53,6 @@ my $builder = $class->new(
+ 'List::AllUtils' => 0,
+ 'List::MoreUtils' => 0,
+ 'List::MoreUtils::XS' => 0,
+- 'Mozilla::CA' => '20141217',
+ 'Regexp::Common' => 0,
+ 'Log::Log4perl' => 0,
+ 'Unicode::Collate' => '1.12',
+diff --git a/bin/biber b/bin/biber
+index 80ebd39..c4f8897 100755
+--- a/bin/biber
++++ b/bin/biber
+@@ -72,7 +72,6 @@ GetOptions(
+ 'sortfirstinits=s',
+ 'sortlocale|l=s',
+ 'sortupper=s',
+- 'ssl-nointernalca',
+ 'ssl-noverify-host',
+ 'tool',
+ 'tool_align|tool-align', # legacy alias for output_align
+@@ -658,12 +657,6 @@ default sorting (B<--collate|-C>). When
+ using B<--fastsort|-f>, your OS collation locale determines
+ this and this option is ignored (default is true).
+
+-=item B<--ssl-nointernalca>
+-
+-Don't try to use the default Mozilla CA certificates when using HTTPS to fetch remote data.
+-This assumes that the user will set one of the perl LWP::UserAgent module environment variables
+-to find the CA certs.
+-
+ =item B<--ssl-noverify-host>
+
+ Turn off host verification when using HTTPS to fetch remote data sources.
+diff --git a/data/schemata/config.rnc b/data/schemata/config.rnc
+index 9f96fec..2863e14 100644
+--- a/data/schemata/config.rnc
++++ b/data/schemata/config.rnc
+@@ -77,7 +77,6 @@ start = element config {
+ map+
+ }+
+ }? &
+- element ssl-nointernalca { "0" | "1" }? &
+ element ssl-noverify-host { "0" | "1" }? &
+ element tool { "0" | "1" }? &
+ element tool_config { text }? &
+diff --git a/data/schemata/config.rng b/data/schemata/config.rng
+index 3bd7072..8ef9bee 100644
+--- a/data/schemata/config.rng
++++ b/data/schemata/config.rng
+@@ -352,14 +352,6 @@
+ </element>
+ </optional>
+ <optional>
+- <element name="ssl-nointernalca">
+- <choice>
+- <value>0</value>
+- <value>1</value>
+- </choice>
+- </element>
+- </optional>
+- <optional>
+ <element name="ssl-noverify-host">
+ <choice>
+ <value>0</value>
+diff --git a/lib/Biber/Input/file/biblatexml.pm b/lib/Biber/Input/file/biblatexml.pm
+index 4d1878b..8994c0f 100644
+--- a/lib/Biber/Input/file/biblatexml.pm
++++ b/lib/Biber/Input/file/biblatexml.pm
+@@ -97,19 +97,6 @@ sub extract_entries {
+ else {
+ if ($1) { # HTTPS
+ # use IO::Socket::SSL qw(debug99); # useful for debugging SSL issues
+- # We have to explicitly set the cert path because otherwise the https module
+- # can't find the .pem when PAR::Packer'ed
+- # Have to explicitly try to require Mozilla::CA here to get it into %INC below
+- # It may, however, have been removed by some biber unpacked dists
+- if (not exists($ENV{PERL_LWP_SSL_CA_FILE}) and
+- not exists($ENV{PERL_LWP_SSL_CA_PATH}) and
+- not defined(Biber::Config->getoption('ssl-nointernalca')) and
+- eval {require Mozilla::CA}) {
+- # we assume that the default CA file is in .../Mozilla/CA/cacert.pem
+- (my $vol, my $dir, undef) = File::Spec->splitpath( $INC{"Mozilla/CA.pm"} );
+- $dir =~ s/\/$//; # splitpath sometimes leaves a trailing '/'
+- $ENV{PERL_LWP_SSL_CA_FILE} = File::Spec->catpath($vol, "$dir/CA", 'cacert.pem');
+- }
+
+ # fallbacks for, e.g., linux
+ unless (exists($ENV{PERL_LWP_SSL_CA_FILE})) {
+diff --git a/lib/Biber/Input/file/bibtex.pm b/lib/Biber/Input/file/bibtex.pm
+index 24b2772..c70e6e4 100644
+--- a/lib/Biber/Input/file/bibtex.pm
++++ b/lib/Biber/Input/file/bibtex.pm
+@@ -140,19 +140,6 @@ sub extract_entries {
+ else {
+ if ($1) { # HTTPS
+ # use IO::Socket::SSL qw(debug99); # useful for debugging SSL issues
+- # We have to explicitly set the cert path because otherwise the https module
+- # can't find the .pem when PAR::Packer'ed
+- # Have to explicitly try to require Mozilla::CA here to get it into %INC below
+- # It may, however, have been removed by some biber unpacked dists
+- if (not exists($ENV{PERL_LWP_SSL_CA_FILE}) and
+- not exists($ENV{PERL_LWP_SSL_CA_PATH}) and
+- not defined(Biber::Config->getoption('ssl-nointernalca')) and
+- eval {require Mozilla::CA}) {
+- # we assume that the default CA file is in .../Mozilla/CA/cacert.pem
+- (my $vol, my $dir, undef) = File::Spec->splitpath( $INC{"Mozilla/CA.pm"} );
+- $dir =~ s/\/$//; # splitpath sometimes leaves a trailing '/'
+- $ENV{PERL_LWP_SSL_CA_FILE} = File::Spec->catpath($vol, "$dir/CA", 'cacert.pem');
+- }
+
+ # fallbacks for, e.g., linux
+ unless (exists($ENV{PERL_LWP_SSL_CA_FILE})) {
+diff --git a/lib/Biber/Input/file/endnotexml.pm b/lib/Biber/Input/file/endnotexml.pm
+index bf62a80..342b3b2 100644
+--- a/lib/Biber/Input/file/endnotexml.pm
++++ b/lib/Biber/Input/file/endnotexml.pm
+@@ -111,19 +111,6 @@ sub extract_entries {
+ $logger->info("Data source '$source' is a remote EndNote XML datasource - fetching ...");
+ if ($1) { # HTTPS
+ # use IO::Socket::SSL qw(debug99); # useful for debugging SSL issues
+- # We have to explicitly set the cert path because otherwise the https module
+- # can't find the .pem when PAR::Packer'ed
+- # Have to explicitly try to require Mozilla::CA here to get it into %INC below
+- # It may, however, have been removed by some biber unpacked dists
+- if (not exists($ENV{PERL_LWP_SSL_CA_FILE}) and
+- not exists($ENV{PERL_LWP_SSL_CA_PATH}) and
+- not defined(Biber::Config->getoption('ssl-nointernalca')) and
+- eval {require Mozilla::CA}) {
+- # we assume that the default CA file is in .../Mozilla/CA/cacert.pem
+- (my $vol, my $dir, undef) = File::Spec->splitpath( $INC{"Mozilla/CA.pm"} );
+- $dir =~ s/\/$//; # splitpath sometimes leaves a trailing '/'
+- $ENV{PERL_LWP_SSL_CA_FILE} = File::Spec->catpath($vol, "$dir/CA", 'cacert.pem');
+- }
+
+ # fallbacks for, e.g., linux
+ unless (exists($ENV{PERL_LWP_SSL_CA_FILE})) {
+diff --git a/lib/Biber/Input/file/ris.pm b/lib/Biber/Input/file/ris.pm
+index bc389c2..56f8d93 100644
+--- a/lib/Biber/Input/file/ris.pm
++++ b/lib/Biber/Input/file/ris.pm
+@@ -110,19 +110,6 @@ sub extract_entries {
+ else {
+ if ($1) { # HTTPS
+ # use IO::Socket::SSL qw(debug99); # useful for debugging SSL issues
+- # We have to explicitly set the cert path because otherwise the https module
+- # can't find the .pem when PAR::Packer'ed
+- # Have to explicitly try to require Mozilla::CA here to get it into %INC below
+- # It may, however, have been removed by some biber unpacked dists
+- if (not exists($ENV{PERL_LWP_SSL_CA_FILE}) and
+- not exists($ENV{PERL_LWP_SSL_CA_PATH}) and
+- not defined(Biber::Config->getoption('ssl-nointernalca')) and
+- eval {require Mozilla::CA}) {
+- # we assume that the default CA file is in .../Mozilla/CA/cacert.pem
+- (my $vol, my $dir, undef) = File::Spec->splitpath( $INC{"Mozilla/CA.pm"} );
+- $dir =~ s/\/$//; # splitpath sometimes leaves a trailing '/'
+- $ENV{PERL_LWP_SSL_CA_FILE} = File::Spec->catpath($vol, "$dir/CA", 'cacert.pem');
+- }
+
+ # fallbacks for, e.g., linux
+ unless (exists($ENV{PERL_LWP_SSL_CA_FILE})) {
+diff --git a/lib/Biber/Input/file/zoterordfxml.pm b/lib/Biber/Input/file/zoterordfxml.pm
+index 6dbb3f9..15bc3f6 100644
+--- a/lib/Biber/Input/file/zoterordfxml.pm
++++ b/lib/Biber/Input/file/zoterordfxml.pm
+@@ -123,19 +123,6 @@ sub extract_entries {
+ $logger->info("Data source '$source' is a remote Zotero RDF/XML data source - fetching ...");
+ if ($1) { # HTTPS
+ # use IO::Socket::SSL qw(debug99); # useful for debugging SSL issues
+- # We have to explicitly set the cert path because otherwise the https module
+- # can't find the .pem when PAR::Packer'ed
+- # Have to explicitly try to require Mozilla::CA here to get it into %INC below
+- # It may, however, have been removed by some biber unpacked dists
+- if (not exists($ENV{PERL_LWP_SSL_CA_FILE}) and
+- not exists($ENV{PERL_LWP_SSL_CA_PATH}) and
+- not defined(Biber::Config->getoption('ssl-nointernalca')) and
+- eval {require Mozilla::CA}) {
+- # we assume that the default CA file is in .../Mozilla/CA/cacert.pem
+- (my $vol, my $dir, undef) = File::Spec->splitpath( $INC{"Mozilla/CA.pm"} );
+- $dir =~ s/\/$//; # splitpath sometimes leaves a trailing '/'
+- $ENV{PERL_LWP_SSL_CA_FILE} = File::Spec->catpath($vol, "$dir/CA", 'cacert.pem');
+- }
+
+ # fallbacks for, e.g., linux
+ unless (exists($ENV{PERL_LWP_SSL_CA_FILE})) {
+--
+2.4.2
+