summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2015-05-01 06:51:05 +0000
committerSergey Popov <pinkbyte@gentoo.org>2015-05-01 06:51:05 +0000
commitc2a1652c6edd394e1285577068ee700e49e25b02 (patch)
tree6cf694a37d0b91309449c55b2a7ef1876d398188 /net-news
parentStable for PPC64 (bug #535644). (diff)
downloadgentoo-2-c2a1652c6edd394e1285577068ee700e49e25b02.tar.gz
gentoo-2-c2a1652c6edd394e1285577068ee700e49e25b02.tar.bz2
gentoo-2-c2a1652c6edd394e1285577068ee700e49e25b02.zip
Version bump, wrt bug #548184. Drop old vulnerable version, wrt bug #533654. Thanks to Jack Miller <jack AT codezen.org> for discovering this issue
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x60C0742D1F357D42)
Diffstat (limited to 'net-news')
-rw-r--r--net-news/canto-daemon/ChangeLog9
-rw-r--r--net-news/canto-daemon/canto-daemon-0.9.1.ebuild (renamed from net-news/canto-daemon/canto-daemon-0.8.2.ebuild)15
2 files changed, 20 insertions, 4 deletions
diff --git a/net-news/canto-daemon/ChangeLog b/net-news/canto-daemon/ChangeLog
index 0b91ce4bf7ed..7515dfdaf161 100644
--- a/net-news/canto-daemon/ChangeLog
+++ b/net-news/canto-daemon/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-news/canto-daemon
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-news/canto-daemon/ChangeLog,v 1.3 2015/04/08 18:17:12 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/canto-daemon/ChangeLog,v 1.4 2015/05/01 06:51:05 pinkbyte Exp $
+
+*canto-daemon-0.9.1 (01 May 2015)
+
+ 01 May 2015; Sergey Popov <pinkbyte@gentoo.org> -canto-daemon-0.8.2.ebuild,
+ +canto-daemon-0.9.1.ebuild:
+ Version bump, wrt bug #548184. Drop old vulnerable version, wrt bug #533654.
+ Thanks to Jack Miller <jack AT codezen.org> for discovering this issue
08 Apr 2015; Michał Górny <mgorny@gentoo.org> canto-daemon-0.8.2.ebuild:
Drop old Python implementations
diff --git a/net-news/canto-daemon/canto-daemon-0.8.2.ebuild b/net-news/canto-daemon/canto-daemon-0.9.1.ebuild
index 9d1e8a0c7a93..f422df1e24e5 100644
--- a/net-news/canto-daemon/canto-daemon-0.8.2.ebuild
+++ b/net-news/canto-daemon/canto-daemon-0.9.1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-news/canto-daemon/canto-daemon-0.8.2.ebuild,v 1.3 2015/04/08 18:17:12 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/canto-daemon/canto-daemon-0.9.1.ebuild,v 1.1 2015/05/01 06:51:05 pinkbyte Exp $
EAPI="5"
PYTHON_COMPAT=( python{3_3,3_4} )
-PYTHON_REQ_USE="xml"
-inherit distutils-r1
+PYTHON_REQ_USE="xml(+),threads(+)"
+inherit distutils-r1 multilib
DESCRIPTION="Daemon part of Canto-NG RSS reader"
HOMEPAGE="http://codezen.org/canto-ng/"
@@ -17,3 +17,12 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="dev-python/feedparser[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/canto-next-${PV}"
+
+python_prepare_all() {
+ # Respect libdir during plugins installation
+ sed -i -e "s:lib/canto:$(get_libdir)/canto:" setup.py || die
+
+ distutils-r1_python_prepare_all
+}