summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGLSAMaker <glsamaker@gentoo.org>2022-08-10 04:07:00 +0000
committerJohn Helmert III <ajak@gentoo.org>2022-08-09 23:17:29 -0500
commitf7375fcfd657cfc3887863e562d7feab296947e9 (patch)
tree8a3d0b60e192e2dcc28e32653012f13fbefcb8ab
parent[ GLSA 202208-08 ] Mozilla Firefox: Multiple Vulnerabilities (diff)
downloadglsa-f7375fcfd657cfc3887863e562d7feab296947e9.tar.gz
glsa-f7375fcfd657cfc3887863e562d7feab296947e9.tar.bz2
glsa-f7375fcfd657cfc3887863e562d7feab296947e9.zip
[ GLSA 202208-09 ] HashiCorp Consul: Multiple Vulnerabilities
Bug: https://bugs.gentoo.org/760696 Bug: https://bugs.gentoo.org/783483 Bug: https://bugs.gentoo.org/802522 Bug: https://bugs.gentoo.org/812497 Bug: https://bugs.gentoo.org/834006 Bug: https://bugs.gentoo.org/838328 Signed-off-by: GLSAMaker <glsamaker@gentoo.org> Signed-off-by: John Helmert III <ajak@gentoo.org>
-rw-r--r--glsa-202208-09.xml55
1 files changed, 55 insertions, 0 deletions
diff --git a/glsa-202208-09.xml b/glsa-202208-09.xml
new file mode 100644
index 0000000..e692833
--- /dev/null
+++ b/glsa-202208-09.xml
@@ -0,0 +1,55 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
+<glsa id="202208-09">
+ <title>HashiCorp Consul: Multiple Vulnerabilities</title>
+ <synopsis>Multiple vulnerabilities have been discovered in HashiCorp Consul, the worst of which could result in denial of service.</synopsis>
+ <product type="ebuild">consul</product>
+ <announced>2022-08-10</announced>
+ <revised count="1">2022-08-10</revised>
+ <bug>760696</bug>
+ <bug>783483</bug>
+ <bug>802522</bug>
+ <bug>812497</bug>
+ <bug>834006</bug>
+ <bug>838328</bug>
+ <access>remote</access>
+ <affected>
+ <package name="app-admin/consul" auto="yes" arch="*">
+ <unaffected range="ge">1.9.17</unaffected>
+ <vulnerable range="lt">1.9.17</vulnerable>
+ </package>
+ </affected>
+ <background>
+ <p>HashiCorp Consul is a tool for service discovery, monitoring and configuration.</p>
+ </background>
+ <description>
+ <p>Multiple vulnerabilities have been discovered in HashiCorp Consul. Please review the CVE identifiers referenced below for details.</p>
+ </description>
+ <impact type="low">
+ <p>Please review the referenced CVE identifiers for details.</p>
+ </impact>
+ <workaround>
+ <p>There is no known workaround at this time.</p>
+ </workaround>
+ <resolution>
+ <p>All HashiCorp Consul users should upgrade to the latest version:</p>
+
+ <code>
+ # emerge --sync
+ # emerge --ask --oneshot --verbose ">=app-admin/consul-1.9.17"
+ </code>
+ </resolution>
+ <references>
+ <uri link="https://nvd.nist.gov/vuln/detail/CVE-2020-25201">CVE-2020-25201</uri>
+ <uri link="https://nvd.nist.gov/vuln/detail/CVE-2020-25864">CVE-2020-25864</uri>
+ <uri link="https://nvd.nist.gov/vuln/detail/CVE-2020-28053">CVE-2020-28053</uri>
+ <uri link="https://nvd.nist.gov/vuln/detail/CVE-2021-28156">CVE-2021-28156</uri>
+ <uri link="https://nvd.nist.gov/vuln/detail/CVE-2021-32574">CVE-2021-32574</uri>
+ <uri link="https://nvd.nist.gov/vuln/detail/CVE-2021-36213">CVE-2021-36213</uri>
+ <uri link="https://nvd.nist.gov/vuln/detail/CVE-2021-38698">CVE-2021-38698</uri>
+ <uri link="https://nvd.nist.gov/vuln/detail/CVE-2022-24687">CVE-2022-24687</uri>
+ <uri link="https://nvd.nist.gov/vuln/detail/CVE-2022-29153">CVE-2022-29153</uri>
+ </references>
+ <metadata tag="requester" timestamp="2022-08-10T04:07:00.827758Z">ajak</metadata>
+ <metadata tag="submitter" timestamp="2022-08-10T04:07:00.832395Z">ajak</metadata>
+</glsa> \ No newline at end of file