summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2018-10-10 12:13:05 +0200
committerAgostino Sarubbo <ago@gentoo.org>2018-10-10 12:13:05 +0200
commit1db971b598e4b2f13ec81a53546e1b69cb1bf1f0 (patch)
treeb74849e37a9449af01642266c2bbb587e378c452 /sys-kernel/dappersec-sources/dappersec-sources-4.9.131.ebuild
parentmedia-video/smtube: removal, it is already in the main tree (diff)
downloadago-1db971b598e4b2f13ec81a53546e1b69cb1bf1f0.tar.gz
ago-1db971b598e4b2f13ec81a53546e1b69cb1bf1f0.tar.bz2
ago-1db971b598e4b2f13ec81a53546e1b69cb1bf1f0.zip
sys-kernel/dappersec-sources: initial commit
Signed-off-by: Agostino Sarubbo <ago@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.10 Manifest-Sign-Key: 0xEC7C8D80008F261A
Diffstat (limited to 'sys-kernel/dappersec-sources/dappersec-sources-4.9.131.ebuild')
-rw-r--r--sys-kernel/dappersec-sources/dappersec-sources-4.9.131.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-kernel/dappersec-sources/dappersec-sources-4.9.131.ebuild b/sys-kernel/dappersec-sources/dappersec-sources-4.9.131.ebuild
new file mode 100644
index 0000000..6ce437c
--- /dev/null
+++ b/sys-kernel/dappersec-sources/dappersec-sources-4.9.131.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# See https://blogs.gentoo.org/ago/2017/08/21/sys-kernel-grsecurity-sources-available
+
+EAPI="6"
+
+ETYPE="sources"
+K_GENPATCHES_VER="not-empty" # Set to not-empty to avoid the useless download of patch-*.xz
+
+inherit kernel-2
+detect_version
+detect_arch
+
+GRSECURITY_URI="https://dev.gentoo.org/~ago/distfiles/${PN}/${PN}-${PV}.tar.xz"
+SRC_URI="${KERNEL_URI} ${GRSECURITY_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/${PN}-${PV}.tar.xz"
+
+DESCRIPTION="Unofficial port of the last public grsecurity patch plus Gentoo patchset"
+HOMEPAGE="https://github.com/dapperlinux/dapper-secure-kernel-patchset-stable"
+IUSE="deblob"
+KEYWORDS="-* ~amd64"
+RDEPEND=">=sys-devel/gcc-4.5"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-3.1*"
+
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}