summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2015-02-21 00:16:52 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2015-02-21 00:16:52 +0300
commitaca3a82ec1a2e5e6dd25608cb5808c8bd58ea705 (patch)
tree3e6cba33e1c1565faabba25352b248c0095190a9
parentAdd experimental python bindings (diff)
downloadalexxy-aca3a82ec1a2e5e6dd25608cb5808c8bd58ea705.tar.gz
alexxy-aca3a82ec1a2e5e6dd25608cb5808c8bd58ea705.tar.bz2
alexxy-aca3a82ec1a2e5e6dd25608cb5808c8bd58ea705.zip
update to recent changes
Package-Manager: portage-2.2.17
-rw-r--r--sci-chemistry/gromacs/gromacs-9999.ebuild25
1 files changed, 16 insertions, 9 deletions
diff --git a/sci-chemistry/gromacs/gromacs-9999.ebuild b/sci-chemistry/gromacs/gromacs-9999.ebuild
index d26c345..e95e4d2 100644
--- a/sci-chemistry/gromacs/gromacs-9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -29,7 +29,7 @@ else
test? ( http://gerrit.gromacs.org/download/regressiontests-${TEST_PV}.tar.gz )"
fi
-ACCE_IUSE="sse2 sse4_1 avx_128_fma avx_256 avx2_256"
+ACCE_IUSE="cpu_flags_x86_sse2 cpu_flags_x86_sse4_1 cpu_flags_x86_fma4 cpu_flags_x86_avx cpu_flags_x86_avx2"
DESCRIPTION="The ultimate molecular dynamics simulation package"
HOMEPAGE="http://www.gromacs.org/"
@@ -58,7 +58,7 @@ CDEPEND="
python? (
dev-python/numpy
dev-python/sip
- )
+ )
"
DEPEND="${CDEPEND}
virtual/pkgconfig
@@ -74,7 +74,8 @@ REQUIRED_USE="
|| ( single-precision double-precision )
cuda? ( single-precision )
mkl? ( !blas !fftw !lapack )
- python? ( ${PYTHON_REQUIRED_USE} )"
+ python? ( ${PYTHON_REQUIRED_USE} )
+ "
DOCS=( AUTHORS README )
@@ -133,11 +134,11 @@ src_configure() {
#go from slowest to fastest acceleration
local acce="None"
- use sse2 && acce="SSE2"
- use sse4_1 && acce="SSE4.1"
- use avx_128_fma && acce="AVX_128_FMA"
- use avx_256 && acce="AVX_256"
- use avx2_256 && acce="AVX2_256"
+ use cpu_flags_x86_sse2 && acce="SSE2"
+ use cpu_flags_x86_sse4_1 && acce="SSE4.1"
+ use cpu_flags_x86_fma4 && acce="AVX_128_FMA"
+ use cpu_flags_x86_avx && acce="AVX_256"
+ use cpu_flags_x86_avx2 && acce="AVX2_256"
#to create man pages, build tree binaries are executed (bug #398437)
[[ ${CHOST} = *-darwin* ]] && \
@@ -266,6 +267,12 @@ src_install() {
rm -f "${ED}"usr/bin/GMXRC*
rm -f "${ED}"usr/lib*/libtng*.a
+ #workaround for libtng
+ if [[ $(get_libdir) != lib ]]; then
+ mv "${ED}"usr/lib/libtng* "${ED}usr/$(get_libdir)" || die
+ rmdir "${ED}"usr/lib || die
+ fi
+
readme.gentoo_create_doc
}