summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2019-04-23 18:28:15 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2019-04-23 19:16:12 +0300
commitf62ec00c84782c5ed58901385c9bfd697d7e568f (patch)
tree646463a15368119d21b316d5e4dfce140bbb731d
parentdev-python/jinja: Resurect old verion (diff)
downloadalexxy-f62ec00c84782c5ed58901385c9bfd697d7e568f.tar.gz
alexxy-f62ec00c84782c5ed58901385c9bfd697d7e568f.tar.bz2
alexxy-f62ec00c84782c5ed58901385c9bfd697d7e568f.zip
dev-python/pkginfo: Version bump
Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
-rw-r--r--dev-python/pkginfo/Manifest1
-rw-r--r--dev-python/pkginfo/metadata.xml11
-rw-r--r--dev-python/pkginfo/pkginfo-1.5.0.1.ebuild47
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pkginfo/Manifest b/dev-python/pkginfo/Manifest
new file mode 100644
index 0000000..404ce42
--- /dev/null
+++ b/dev-python/pkginfo/Manifest
@@ -0,0 +1 @@
+DIST pkginfo-1.5.0.1.tar.gz 34496 SHA256 7424f2c8511c186cd5424bbf31045b77435b37a8d604990b79d4e70d741148bb SHA512 319bb403970affd5a4222dfdb3d17738630d1350ea84e51ad1bebc6c8c72e0dcfd69a4eaf5e7bd156b8e605d806357922c05cc994dcafb01b7a33c617b2df447 WHIRLPOOL f2f8e138d4005e329e5d8da8a8312bca08239d427cc692a5a90c7f83ea8be8e9c3532cfd5b7a848b907f161c487c8bfdf2a2e362fc93653bdcc06357d32bdc76
diff --git a/dev-python/pkginfo/metadata.xml b/dev-python/pkginfo/metadata.xml
new file mode 100644
index 0000000..c105533
--- /dev/null
+++ b/dev-python/pkginfo/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pkginfo</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pkginfo/pkginfo-1.5.0.1.ebuild b/dev-python/pkginfo/pkginfo-1.5.0.1.ebuild
new file mode 100644
index 0000000..b4837c7
--- /dev/null
+++ b/dev-python/pkginfo/pkginfo-1.5.0.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides an API for querying the distutils metadata written in a PKG-INFO file"
+HOMEPAGE="https://pypi.org/project/pkginfo/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Disable tests that seek to read the version of pkginfo from an installed state
+ # These test will still become installed and testable once installed
+ sed -e 's:test_w_directory_no_EGG_INFO:_&:' \
+ -e 's:test_w_module_and_metadata_version:_&:' \
+ -e 's:test_w_package_name_and_metadata_version:_&:' \
+ -i pkginfo/tests/test_utils.py || die
+ sed -e 's:test_ctor_w_path_nested_egg_info:_&:' \
+ -i pkginfo/tests/test_develop.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" -m unittest discover || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/.build/html/. )
+ distutils-r1_python_install_all
+}