summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory A. Pratt <anarchy@gentoo.org>2012-05-12 08:48:06 -0500
committerJory A. Pratt <anarchy@gentoo.org>2012-05-12 08:48:06 -0500
commited3ff7d46e7c269e52364ecb90250d6edc9f2d2c (patch)
treec4677852e41d350a3b7ace2aaaf26f707d89ae9b
parentupdate dbus with --disable-libaudit support to prevent breakage on (diff)
downloadanarchy-ed3ff7d46e7c269e52364ecb90250d6edc9f2d2c.tar.gz
anarchy-ed3ff7d46e7c269e52364ecb90250d6edc9f2d2c.tar.bz2
anarchy-ed3ff7d46e7c269e52364ecb90250d6edc9f2d2c.zip
add snapshot of lxdm-0.4.2
-rw-r--r--lxde-base/lxdm/Manifest3
-rw-r--r--lxde-base/lxdm/files/lxdm-0.4.1-pam_console-disable.patch9
-rw-r--r--lxde-base/lxdm/lxdm-0.4.2.ebuild65
3 files changed, 77 insertions, 0 deletions
diff --git a/lxde-base/lxdm/Manifest b/lxde-base/lxdm/Manifest
new file mode 100644
index 0000000..06a49dd
--- /dev/null
+++ b/lxde-base/lxdm/Manifest
@@ -0,0 +1,3 @@
+AUX lxdm-0.4.1-pam_console-disable.patch 344 RMD160 faa1026b361b4e5bf0b002651cb1bcf45f5f8800 SHA1 8169882a4bcdeeba34586d0fd5bd0dc3048556bc SHA256 51d1a0f0b5749e451e313df3bd3d08b3f5181f00eb01993973393c1b4dcd8ad2
+DIST lxdm-0.4.2.tar.gz 294145 RMD160 97e22d417ce6a85e1c2ff61462b148eb87596f88 SHA1 8eb40d0edfabd1cbf93eafb78e2a9a613b5b5bd5 SHA256 c2d266ec416de20908571719eeace57194ee6d8b6ffa1e65243eb18cf3a24c2e
+EBUILD lxdm-0.4.2.ebuild 1434 RMD160 fd1f2f14fa8f293b77669a87c3b5b35c8df7b92d SHA1 653a6edb62765495f312a58b28064a42fdf4b96a SHA256 ead5519c8343972494aa0b55b07f99cce58fbc7c512389932fa7bb4f42e0011a
diff --git a/lxde-base/lxdm/files/lxdm-0.4.1-pam_console-disable.patch b/lxde-base/lxdm/files/lxdm-0.4.1-pam_console-disable.patch
new file mode 100644
index 0000000..628e9a5
--- /dev/null
+++ b/lxde-base/lxdm/files/lxdm-0.4.1-pam_console-disable.patch
@@ -0,0 +1,9 @@
+--- lxdm-0.4.0.orig/pam/lxdm
++++ lxdm-0.4.0/pam/lxdm
+@@ -5,5 +5,5 @@ account include system-auth
+ session optional pam_keyinit.so force revoke
+ session include system-auth
+ session required pam_loginuid.so
+-session optional pam_console.so
++#session optional pam_console.so
+ session optional pam_gnome_keyring.so auto_start
diff --git a/lxde-base/lxdm/lxdm-0.4.2.ebuild b/lxde-base/lxdm/lxdm-0.4.2.ebuild
new file mode 100644
index 0000000..bb68ff0
--- /dev/null
+++ b/lxde-base/lxdm/lxdm-0.4.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxdm/lxdm-0.4.1-r5.ebuild,v 1.1 2012/05/07 09:58:01 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="LXDE Display Manager"
+HOMEPAGE="http://lxde.org"
+SRC_URI="http://dev.gentoo.org/~anarchy/dist/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug gtk3 nls pam"
+
+RDEPEND="sys-auth/consolekit
+ x11-libs/libxcb
+ gtk3? ( x11-libs/gtk+:3 )
+ !gtk3? ( x11-libs/gtk+:2 )
+ nls? ( sys-devel/gettext )
+ pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig"
+
+src_prepare() {
+ # Upstream bug, tarball contains pre-made lxdm.conf
+ rm "${S}"/data/lxdm.conf || die
+
+ # There is consolekit
+ epatch "${FILESDIR}/${PN}-0.4.1-pam_console-disable.patch"
+
+ # this replaces the bootstrap/autogen script in most packages
+ eautoreconf
+
+ # process LINGUAS
+ if use nls; then
+ einfo "Running intltoolize ..."
+ intltoolize --force --copy --automake || die
+ strip-linguas -i "${S}/po" || die
+ fi
+}
+src_configure() {
+ econf --enable-password \
+ --with-x \
+ --with-xconn=xcb \
+ $(use_enable gtk3) \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ $(use_with pam)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README TODO || die
+}
+
+pkg_postinst() {
+ echo
+ elog "LXDM in the early stages of development!"
+ echo
+}