summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/mousepad/mousepad-0.4.0-r1.ebuild')
-rw-r--r--app-editors/mousepad/mousepad-0.4.0-r1.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/app-editors/mousepad/mousepad-0.4.0-r1.ebuild b/app-editors/mousepad/mousepad-0.4.0-r1.ebuild
deleted file mode 100644
index b1f878e..0000000
--- a/app-editors/mousepad/mousepad-0.4.0-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit gnome2-utils xdg-utils
-
-DESCRIPTION="GTK+-based editor for the Xfce Desktop Environment"
-HOMEPAGE="https://git.xfce.org/apps/mousepad/about/"
-SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="dbus gtk3"
-
-RDEPEND=">=dev-libs/glib-2.30:2=
- dbus? ( >=dev-libs/dbus-glib-0.100:0= )
- !gtk3? ( >=x11-libs/gtk+-2.24:2=
- x11-libs/gtksourceview:2.0= )
- gtk3? ( x11-libs/gtk+:3=
- x11-libs/gtksourceview:3.0= )"
-DEPEND="${RDEPEND}
- dev-lang/perl
- dev-util/intltool
- sys-devel/gettext
- virtual/pkgconfig"
-
-DOCS=( AUTHORS ChangeLog NEWS README TODO )
-
-PATCHES=(
- "${FILESDIR}"/${P}-dbus-filename-passing.patch
- "${FILESDIR}"/${P}-dbus-filename-passing-optimization.patch
- "${FILESDIR}"/${P}-dont-show-hidden-gsv.patch
- "${FILESDIR}"/${P}-prevent-weird-cycle-gsettings.patch
- )
-
-
-src_configure() {
- local myconf=(
- $(use_enable dbus)
- $(use_enable gtk3)
- )
-
- econf "${myconf[@]}"
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- gnome2_schemas_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- gnome2_schemas_update
- xdg_desktop_database_update
-}