summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2015-10-22 13:21:42 +0200
committerChristoph Mende <angelos@gentoo.org>2015-10-22 13:21:42 +0200
commitc1c6c2b501eb78ababab2761a0308eff8f52888d (patch)
tree33499ab2cce24c13fc57a9213bdd4e8a470ce539
parentdev-libs/sqlheavy: remove 0.1.1 (diff)
downloadangelos-c1c6c2b501eb78ababab2761a0308eff8f52888d.tar.gz
angelos-c1c6c2b501eb78ababab2761a0308eff8f52888d.tar.bz2
angelos-c1c6c2b501eb78ababab2761a0308eff8f52888d.zip
dev-libs/sqlheavy: update REPO_URI/HOMEPAGE and migrate to vala.eclass
-rw-r--r--dev-libs/sqlheavy/sqlheavy-9999.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-libs/sqlheavy/sqlheavy-9999.ebuild b/dev-libs/sqlheavy/sqlheavy-9999.ebuild
index e1351da..0db62e9 100644
--- a/dev-libs/sqlheavy/sqlheavy-9999.ebuild
+++ b/dev-libs/sqlheavy/sqlheavy-9999.ebuild
@@ -3,11 +3,12 @@
# $Id$
EAPI=4
-inherit autotools git-2
+VALA_MIN_API_VERSION=0.16
+inherit autotools git-2 vala
DESCRIPTION="GObject SQLite wrapper"
-HOMEPAGE="http://code.google.com/p/sqlheavy/"
-EGIT_REPO_URI="git://gitorious.org/${PN}/${PN}.git"
+HOMEPAGE="https://github.com/nemequ/sqlheavy"
+EGIT_REPO_URI="https://github.com/nemequ/${PN}.git"
LICENSE="LGPL-2.1"
SLOT="0"
@@ -15,7 +16,7 @@ KEYWORDS=""
IUSE="doc examples"
RDEPEND=">=dev-db/sqlite-3.6.20:3
- dev-lang/vala:0.16
+ $(vala_depend)
>=dev-libs/glib-2.22:2
>=x11-libs/gtk+-2.24:2"
DEPEND="${RDEPEND}
@@ -27,10 +28,10 @@ DOCS=( AUTHORS NEWS README )
src_prepare() {
sed -i -e "/examples/d" Makefile.am # don't compile examples
eautoreconf
+ vala_src_prepare
}
src_configure() {
- VALAC=$(type -p valac-0.16) \
econf \
--disable-static \
$(use_enable doc valadoc)