summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/foobot/foobot-9999.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/net-irc/foobot/foobot-9999.ebuild b/net-irc/foobot/foobot-9999.ebuild
index 167016f..748a9c7 100644
--- a/net-irc/foobot/foobot-9999.ebuild
+++ b/net-irc/foobot/foobot-9999.ebuild
@@ -2,8 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
-inherit autotools git-2
+EAPI=5
+VALA_MIN_API_VERSION=0.16
+inherit autotools git-2 vala
DESCRIPTION="an IRC bot written in Vala with support for dynamic plugins and a sqlite3-based database"
HOMEPAGE="https://github.com/cmende/foobot-vala"
@@ -19,13 +20,9 @@ RDEPEND="dev-libs/glib:2
dev-libs/libpeas
dev-libs/sqlheavy"
DEPEND="${RDEPEND}
- dev-lang/vala:0.16
+ $(vala_depend)
virtual/pkgconfig"
-src_configure() {
- VALAC="$(type -p valac-0.16)" econf
-}
-
src_install() {
default
find "${ED}" -name "*.la" -delete || die