summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/dracut/dracut-0.4.ebuild')
-rw-r--r--sys-boot/dracut/dracut-0.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-boot/dracut/dracut-0.4.ebuild b/sys-boot/dracut/dracut-0.4.ebuild
new file mode 100644
index 0000000..55c3d9e
--- /dev/null
+++ b/sys-boot/dracut/dracut-0.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+DESCRIPTION="Dracut is a new initramfs infrastructure."
+HOMEPAGE="http://apps.sourceforge.net/trac/dracut/wiki"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-arch/cpio
+ sys-fs/udev
+ sys-apps/util-linux
+ sys-devel/binutils
+ sys-apps/coreutils
+ sys-apps/module-init-tools
+ sys-apps/findutils
+ sys-apps/grep
+ sys-apps/openrc
+ "
+
+#src_prepare() {
+ #run sed which adds CFLAGS to make file
+#}
+
+src_install() {
+ #pkglibdir=/usr/libexec/dracut
+ emake install DESTDIR="${D}" sbindir=/sbin sysconfdir=/etc \
+ || die "emake install failed"
+}