summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2016-06-04 18:36:44 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2016-06-04 18:36:44 +0300
commitfee618cafc9d888ca1f13ff35ec7e098fd91c184 (patch)
tree6f7807546cfbf62a14f1ebfa512947ce17cf968b
parentlibhx: fixed in the portage tree (diff)
downloadbircoph-fee618ca.tar.gz
bircoph-fee618ca.tar.bz2
bircoph-fee618ca.zip
net-libs/libupnp: fix bug 556604
Package-Manager: portage-2.3.0_rc1 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
-rw-r--r--net-libs/libupnp/Manifest1
-rw-r--r--net-libs/libupnp/files/libupnp-1.6.19-docs-install.patch13
-rw-r--r--net-libs/libupnp/files/libupnp-1.6.19-suse.patch132
-rw-r--r--net-libs/libupnp/libupnp-1.6.19.ebuild53
-rw-r--r--net-libs/libupnp/metadata.xml19
5 files changed, 218 insertions, 0 deletions
diff --git a/net-libs/libupnp/Manifest b/net-libs/libupnp/Manifest
new file mode 100644
index 0000000..e86b7dc
--- /dev/null
+++ b/net-libs/libupnp/Manifest
@@ -0,0 +1 @@
+DIST libupnp-1.6.19.tar.bz2 1213439 SHA256 b3142b39601243b50532eec90f4a27dba85eb86f58d4b849ac94edeb29d9b22a SHA512 97af62a7483cc19cfe80157cbc3383c1b4b7c9c39b848f4ed063784b74df0b9b0527f7b467e01451e0a44dbf9e8a9eab510619146a6ee1e3dce46f3e4af6e661 WHIRLPOOL fe3ed0115c76872b45eb3f16909e23c61b004f028b745be17346b94dffd7c90108420cf71f50f73aa4ef241403b65b9d1c72926af3044ffacdae11f9649dad68
diff --git a/net-libs/libupnp/files/libupnp-1.6.19-docs-install.patch b/net-libs/libupnp/files/libupnp-1.6.19-docs-install.patch
new file mode 100644
index 0000000..622f58a
--- /dev/null
+++ b/net-libs/libupnp/files/libupnp-1.6.19-docs-install.patch
@@ -0,0 +1,13 @@
+--- libupnp-1.6.19/upnp/sample/Makefile.am.orig 2013-11-15 19:50:02.000000000 +0400
++++ libupnp-1.6.19/upnp/sample/Makefile.am 2016-06-03 20:30:43.545081667 +0300
+@@ -65,8 +65,8 @@
+ if WITH_DOCUMENTATION
+ examplesdir = $(docdir)/examples
+ examples_DATA = \
+- $(tv_ctrlpt_SOURCES) \
+- $(tv_device_SOURCES)
++ $(sort $(tv_ctrlpt_SOURCES) \
++ $(tv_device_SOURCES) )
+ endif
+
+ EXTRA_DIST = \
diff --git a/net-libs/libupnp/files/libupnp-1.6.19-suse.patch b/net-libs/libupnp/files/libupnp-1.6.19-suse.patch
new file mode 100644
index 0000000..75a7f0d
--- /dev/null
+++ b/net-libs/libupnp/files/libupnp-1.6.19-suse.patch
@@ -0,0 +1,132 @@
+--- configure.ac 2013-01-29 16:39:56.000000000 +0100
++++ configure.ac 2013-02-17 10:40:53.680021913 +0100
+@@ -7,9 +7,9 @@
+ # (C) Copyright 2005-2007 Rémi Turboult <r3mi@users.sourceforge.net>
+ #
+
+-AC_PREREQ(2.60)
++AC_PREREQ([2.60])
+
+-AC_INIT([libupnp], [1.6.19], [mroberto@users.sourceforge.net])
++AC_INIT([libupnp],[1.6.19],[mroberto@users.sourceforge.net])
+ dnl ############################################################################
+ dnl # *Independently* of the above libupnp package version, the libtool version
+ dnl # of the 3 libraries need to be updated whenever there is a change released:
+@@ -366,7 +366,6 @@
+ # installed libraries.
+ #
+ AC_CONFIG_HEADERS([autoconfig.h upnp/inc/upnpconfig.h])
+-#AC_SYS_LARGEFILE_SENSITIVE
+
+ AC_REVISION([$Revision: 1.1 $])
+
+@@ -519,10 +519,12 @@
+ #
+ # Checks for programs
+ #
+-AC_PROG_CC
++AC_PROG_CC_STDC
++AC_USE_SYSTEM_EXTENSIONS
++AC_SYS_LARGEFILE
+ AM_PROG_CC_C_O
+ m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
+-AC_PROG_LIBTOOL
++LT_INIT
+ AC_PROG_INSTALL
+ AC_PROG_MAKE_SET
+ AC_PROG_EGREP
+@@ -532,9 +534,7 @@
+ #:
+ # Use -O0 in debug so that variables do not get optimized out
+ AX_CFLAGS_GCC_OPTION([-O0, -g])
+- else
+- # add optimise for size
+- AX_CFLAGS_GCC_OPTION([-Os])
++
+ fi
+ ;;
+ esac
+@@ -548,8 +548,7 @@
+ #
+ AC_TYPE_SIZE_T
+ AC_TYPE_OFF_T
+-AC_DEFINE([_LARGE_FILE_SOURCE], [], [Large files support])
+-AC_DEFINE([_FILE_OFFSET_BITS], [64], [File Offset size])
++
+
+
+ #
+--- ixml/Makefile.am.orig
++++ ixml/Makefile.am
+@@ -7,7 +7,7 @@
+
+ SUBDIRS = doc
+
+-AM_CPPFLAGS = -I$(srcdir)/inc -I$(srcdir)/src/inc
++AM_CPPFLAGS = -include $(top_builddir)/autoconfig.h -I$(srcdir)/inc -I$(srcdir)/src/inc
+ AM_CFLAGS =
+
+ LDADD = libixml.la
+--- threadutil/Makefile.am.orig
++++ threadutil/Makefile.am
+@@ -4,7 +4,7 @@
+ # (C) Copyright 2005 Remi Turboult <r3mi@users.sourceforge.net>
+ #
+
+-AM_CPPFLAGS = -I$(srcdir)/inc -I$(srcdir)/src/inc
++AM_CPPFLAGS = -include $(top_builddir)/autoconfig.h -I$(srcdir)/inc -I$(srcdir)/src/inc
+
+ if ENABLE_DEBUG
+ AM_CPPFLAGS += -DDEBUG -DSTATS
+--- upnp/src/api/UpnpString.c.orig
++++ upnp/src/api/UpnpString.c
+@@ -28,38 +28,6 @@
+ /* Other systems have strncasecmp */
+ #endif
+
+-#ifndef UPNP_USE_MSVCPP
+- /* VC has strnlen which is already included but with (potentially) different linkage */
+- /* strnlen() is a GNU extension. */
+- #if HAVE_STRNLEN
+- extern size_t strnlen(const char *s, size_t maxlen);
+- #else /* HAVE_STRNLEN */
+- static size_t strnlen(const char *s, size_t n)
+- {
+- const char *p = (const char *)memchr(s, 0, n);
+- return p ? p - s : n;
+- }
+- #endif /* HAVE_STRNLEN */
+-#endif /* WIN32 */
+-
+-/* strndup() is a GNU extension. */
+-#if HAVE_STRNDUP && !defined(WIN32)
+- extern char *strndup(__const char *__string, size_t __n);
+-#else /* HAVE_STRNDUP && !defined(WIN32) */
+- static char *strndup(const char *__string, size_t __n)
+- {
+- size_t strsize = strnlen(__string, __n);
+- char *newstr = (char *)malloc(strsize + 1);
+- if (newstr == NULL)
+- return NULL;
+-
+- strncpy(newstr, __string, strsize);
+- newstr[strsize] = 0;
+-
+- return newstr;
+- }
+-#endif /* HAVE_STRNDUP && !defined(WIN32) */
+-
+ /*!
+ * \brief Internal implementation of the class UpnpString.
+ *
+--- upnp/Makefile.am.orig
++++ upnp/Makefile.am
+@@ -6,7 +6,7 @@
+
+ SUBDIRS = doc . sample
+
+-AM_CPPFLAGS = \
++AM_CPPFLAGS = -include $(top_builddir)/autoconfig.h \
+ -I$(srcdir)/inc \
+ -I$(top_srcdir)/threadutil/inc \
+ -I$(top_srcdir)/ixml/inc
diff --git a/net-libs/libupnp/libupnp-1.6.19.ebuild b/net-libs/libupnp/libupnp-1.6.19.ebuild
new file mode 100644
index 0000000..c589c65
--- /dev/null
+++ b/net-libs/libupnp/libupnp-1.6.19.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="An Portable Open Source UPnP Development Kit"
+HOMEPAGE="http://pupnp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pupnp/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux"
+IUSE="debug doc ipv6 static-libs"
+
+DOCS="NEWS README ChangeLog"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-suse.patch \
+ "${FILESDIR}"/${P}-docs-install.patch
+
+ # fix tests
+ chmod +x ixml/test/test_document.sh || die
+
+ eautoreconf
+}
+
+src_configure() {
+ use x86-fbsd && append-flags -O1
+ # w/o docdir to avoid sandbox violations
+ econf \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable static-libs static) \
+ $(use_with doc documentation "${EPREFIX}/usr/share/doc/${PF}")
+}
+
+src_install () {
+ default
+ dobin upnp/sample/.libs/tv_{combo,ctrlpt,device}
+ use static-libs || prune_libtool_files
+}
+
+pkg_postinst() {
+ ewarn "Please remember to run revdep-rebuild when upgrading"
+ ewarn "from libupnp 1.4.x to libupnp 1.6.x , so packages"
+ ewarn "gets linked with the new library."
+ echo ""
+ ewarn "The revdep-rebuild script is part of the"
+ ewarn "app-portage/gentoolkit package."
+}
diff --git a/net-libs/libupnp/metadata.xml b/net-libs/libupnp/metadata.xml
new file mode 100644
index 0000000..0fcdbd7
--- /dev/null
+++ b/net-libs/libupnp/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>maq@maqibooy.com</email>
+ <name>Marcus Stjärnås</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>gurligebis@gentoo.org</email>
+ <name>Bjarke Istrup Pedersen</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">pupnp</remote-id>
+ </upstream>
+</pkgmetadata>