summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gmail.com>2011-04-05 20:37:37 +0400
committerAndrew Savchenko <bircoph@gmail.com>2011-04-05 20:37:37 +0400
commitfa3ecfffc366895c6b61b292bee73e713ea071b2 (patch)
treea03680a00ce6887f27181b9bc74ad4db2fab2a52 /net-dialup/openl2tp
parentdepend on virtual/ffmpeg (diff)
downloadbircoph-fa3ecfffc366895c6b61b292bee73e713ea071b2.tar.gz
bircoph-fa3ecfffc366895c6b61b292bee73e713ea071b2.tar.bz2
bircoph-fa3ecfffc366895c6b61b292bee73e713ea071b2.zip
Purge old ebuilds.
Diffstat (limited to 'net-dialup/openl2tp')
-rw-r--r--net-dialup/openl2tp/Manifest1
-rw-r--r--net-dialup/openl2tp/openl2tp-1.8.ebuild154
2 files changed, 0 insertions, 155 deletions
diff --git a/net-dialup/openl2tp/Manifest b/net-dialup/openl2tp/Manifest
index e547945..2e679e4 100644
--- a/net-dialup/openl2tp/Manifest
+++ b/net-dialup/openl2tp/Manifest
@@ -8,6 +8,5 @@ AUX openl2tpd.confd 627 RMD160 c98ef7bdcca067cab855b43f4c28d7db5651dbee SHA1 ab7
AUX openl2tpd.initd 1688 RMD160 41179b0e7a1640aab545f85cd5d5dfbf2a0ff0b2 SHA1 590d8698344ea540301855a492c272d021257229 SHA256 09b5bfc7a5ade30dd7ebb4b87af09a28e3a7e9c65c09fd066c24528b1d29ba1e
DIST openl2tp-1.8.tar.gz 491160 RMD160 29913730809f7ea670c994c175551f31f2ba1e6f SHA1 314a8bb70f9f06bac840200fac0916e80d8d06b3 SHA256 1c97704d4b963a87fbc0e741668d4530933991515ae9ab0dffd11b5444f4860f
EBUILD openl2tp-1.8-r2.ebuild 4282 RMD160 507ef1a4d453c8b0d3926bc7c3275f304dcecf9c SHA1 f567e20db20297899b9bcaab6ea67b4c09739f64 SHA256 7b57ed76cf3a68209741a1826a774c712745fe95e898db4aed4b1a28758083b4
-EBUILD openl2tp-1.8.ebuild 4281 RMD160 213510e71901e500c3280ec49153945e44eb918f SHA1 8fa3aa334127d0f12f65d9ea56bc0fe5f0a66210 SHA256 239f53fd5b080f4ba6bb2ac20ae99ae22a901f2b20abb6f55d456a6525c54ff0
MISC ChangeLog 2030 RMD160 d3ca1c8af016eaef64d26da5b2dc0d18cd6699b1 SHA1 112ee25eca5d3d169388d0372a648f1872d71585 SHA256 67736f50ee0260cc5566b11767f83eeabf012e49a53e26a5ca711dced67d882f
MISC metadata.xml 762 RMD160 416cd2087fe041e02046f07bb6c1677908542c37 SHA1 302dc937814f7d4c32ad16c0300020794f519c0e SHA256 e765957111816f91553fd3db2fef165babdd02ee82d923da6f5b455b684afd72
diff --git a/net-dialup/openl2tp/openl2tp-1.8.ebuild b/net-dialup/openl2tp/openl2tp-1.8.ebuild
deleted file mode 100644
index ab1f460..0000000
--- a/net-dialup/openl2tp/openl2tp-1.8.ebuild
+++ /dev/null
@@ -1,154 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=3
-
-inherit eutils linux-info
-
-DESCRIPTION="Userspace tools for kernel L2TP implementation."
-HOMEPAGE="http://openl2tp.sourceforge.net"
-SRC_URI="mirror://sourceforge/openl2tp/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+client doc examples pppd rpc server -stats"
-
-CDEPEND="net-dialup/ppp
- sys-libs/readline
- "
-DEPEND="${CDEPEND}
- sys-devel/bison
- sys-devel/flex
- "
-RDEPEND="${CDEPEND}
- rpc? ( || (
- net-nds/rpcbind
- net-nds/portmap
- ) )"
-
-CONFIG_CHECK="~PPPOL2TP"
-
-pkg_setup() {
- # check for sane USE flags
- if ! use server && ! use client; then
- eerror
- eerror "You have disabled both server and client parts!"
- eerror "At least one of them must be enabled. ;)"
- eerror
- die "bad USE flags"
- fi
- # kernel requirements
- linux-info_pkg_setup
- if kernel_is -lt 2 6 23; then
- eerror
- eerror "Your kernel is too old. At least 2.6.23 is required to work with this program."
- eerror
- die "kernel is too old"
- fi
-}
-
-src_prepare() {
- # disable -Werror, as warnings may occur on different CFLAGS
- epatch "${FILESDIR}/${P}-werror.patch"
- # use system LDFLAGS
- epatch "${FILESDIR}/${P}-ldflags.patch"
- # let ebuild to control pppd plugins support
- epatch "${FILESDIR}/${P}-pppd.patch"
- # do not gzip man pages, let portage to compress them
- epatch "${FILESDIR}/${P}-man.patch"
- # install l2tpconfig to /usr/sbin with 0700 permissions
- # to make it at least a bit more secure
- epatch "${FILESDIR}/${P}-l2tpconfig.patch"
-}
-
-src_configure() {
- myconf="" # not local, should be used at src_compile()
-
- use client || myconf+="L2TP_FEATURE_LAC_SUPPORT=n \
- L2TP_FEATURE_LAIC_SUPPORT=n \
- L2TP_FEATURE_LAOC_SUPPORT=n "
-
- use server || myconf+="L2TP_FEATURE_LNS_SUPPORT=n \
- L2TP_FEATURE_LNIC_SUPPORT=n \
- L2TP_FEATURE_LNOC_SUPPORT=n "
-
- use rpc || myconf+="L2TP_FEATURE_RPC_MANAGEMENT=n "
-
- use stats && myconf+="L2TP_FEATURE_LOCAL_STAT_FILE=y "
-
- # pppd plugin is only needed for pppd < 2.4.5
- unset PPPD_SUBDIR
- if use pppd; then
- export PPPD_VERSION=$( gawk '{
- if ($2=="VERSION") {
- gsub("\"","",$3);
- print $3
- }
- }' /usr/include/pppd/patchlevel.h ) || die "gawk failed"
- einfo "Building for pppd version $PPPD_VERSION"
-
- # convert version to comparable format
- local ver=$( echo $PPPD_VERSION | gawk -F "." '{
- print lshift($1,16) + lshift($2,8) + $3
- }' )
- if [[ $ver -lt $(( (2<<16) + (4<<8) + 5)) ]]; then
- export PPPD_SUBDIR="pppd"
- else
- ewarn
- ewarn "openl2tp plugins are already integrated in >=net-dialup/ppp-2.4.5"
- fi
- fi
-}
-
-src_compile() {
- # upstream use OPT_CFLAGS for optimizations
- export OPT_CFLAGS=${CFLAGS}
- emake ${myconf} || die "emake failed"
-}
-
-src_install() {
- emake ${myconf} DESTDIR="${D}" install || die "emake install failed"
- dodoc CHANGES INSTALL README
-
- if use examples; then
- dodoc doc/*.c
- fi
-
- if use doc; then
- dodoc doc/*.txt doc/README.event_sock "${FILESDIR}"/openl2tpd.conf.sample
- newdoc plugins/README README.plugins
- use pppd && newdoc pppd/README README.pppd
- docinto ipsec
- dodoc ipsec/*
- fi
-
- newinitd "${FILESDIR}"/openl2tpd.initd openl2tpd
- # init.d script is quite different for RPC and non-RPC versions.
- use rpc || sed -i s/userpc=\"yes\"/userpc=\"no\"/ "${D}/etc/init.d/openl2tpd" || die "sed failed"
- newconfd "${FILESDIR}"/openl2tpd.confd openl2tpd
-}
-
-pkg_postinst() {
- if use rpc; then
- ewarn
- ewarn "RPC control does not provide any auth checks for control connection."
- ewarn "By default localhost only is allowed and l2tpconfig is installed"
- ewarn "accessible only by root, but local users may install or compile binary"
- ewarn "on they own if not prohibited by system administrator."
- ewarn
- ewarn "Therefore DO NOT USE RPC IN INSECURE ENVIRONMENTS!"
- else
- ewarn
- ewarn "Without RPC support you won't be able to use l2tpconfig."
- ewarn "If you are using numerical strings (e.g. login name containing only"
- ewarn "digits) or special characters in password, please use double quotes"
- ewarn "to enclose them."
- fi
- if use stats; then
- ewarn
- ewarn "To enable status files openl2tpd must be started with -S option."
- ewarn "Upstream warns about runtime overhead with status files enabled."
- fi
-}