summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/setroubleshoot-plugins/ChangeLog8
-rw-r--r--sys-apps/setroubleshoot-plugins/Manifest14
-rw-r--r--sys-apps/setroubleshoot-plugins/metadata.xml9
-rw-r--r--sys-apps/setroubleshoot-plugins/setroubleshoot-plugins-3.0.14.2.15.ebuild66
-rw-r--r--sys-apps/setroubleshoot/Manifest8
-rw-r--r--sys-apps/setroubleshoot/setroubleshoot-3.0.32.1.16.ebuild11
6 files changed, 109 insertions, 7 deletions
diff --git a/sys-apps/setroubleshoot-plugins/ChangeLog b/sys-apps/setroubleshoot-plugins/ChangeLog
new file mode 100644
index 0000000..57f986b
--- /dev/null
+++ b/sys-apps/setroubleshoot-plugins/ChangeLog
@@ -0,0 +1,8 @@
+
+
+*setroubleshoot-plugins-3.0.14.2.15 (17 Apr 2011)
+
+ 17 Apr 2011; Anthony G. Basile <blueness@gentoo.org>
+ +setroubleshoot-plugins-3.0.14.2.15.ebuild, +metadata.xml:
+ Initial commit
+
diff --git a/sys-apps/setroubleshoot-plugins/Manifest b/sys-apps/setroubleshoot-plugins/Manifest
new file mode 100644
index 0000000..499c1e5
--- /dev/null
+++ b/sys-apps/setroubleshoot-plugins/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+DIST setroubleshoot-plugins-3.0.14-2.fc15.src.rpm 31564 RMD160 84e99ff65def0e85b0b9edfe5937263299771178 SHA1 60f2cc13fce9ba62e6280dfc08735e083a008455 SHA256 b92fa5a09cfaf7dc9ac5b8ce94bec70843d907b6cc13748e4667066529968531
+EBUILD setroubleshoot-plugins-3.0.14.2.15.ebuild 1513 RMD160 49cd519285854d4a4438bd7e594c23e7dd6679a0 SHA1 c19d51b266e48db175c165b97faa2b527bea1974 SHA256 cc062cf519fbb9d8ab697d7a2745474acdcb3ad9a3193c4938538514f67b53f9
+MISC ChangeLog 187 RMD160 e1f16ea6890db48030ebc01e917099924c0a75aa SHA1 4094a7b66e23a7cedd516cb623a187e255f0f678 SHA256 98c431220bc79ccaa560cb5b48e5768500bd998c0c0d44fa8c5d6f6ec86ac4af
+MISC metadata.xml 260 RMD160 cb2578f6f6e6e46e5ae92dd8a6efaad01a9d869c SHA1 a750ecea19925d6e802e9d79d43f5290e662977f SHA256 93446a91438fa65f110ad12ca91f6e30d22e8b35e09cf4b178c1a6cf5d6e591f
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iEYEAREIAAYFAk2qSzYACgkQl5yvQNBFVTUbDQCfV0eMfO0DJPmAkXHebK+Cp319
+984AnjXQSlt6JJ+RWB10FkU5INU1jscy
+=KubS
+-----END PGP SIGNATURE-----
diff --git a/sys-apps/setroubleshoot-plugins/metadata.xml b/sys-apps/setroubleshoot-plugins/metadata.xml
new file mode 100644
index 0000000..d6fa4db
--- /dev/null
+++ b/sys-apps/setroubleshoot-plugins/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>selinux</herd>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-apps/setroubleshoot-plugins/setroubleshoot-plugins-3.0.14.2.15.ebuild b/sys-apps/setroubleshoot-plugins/setroubleshoot-plugins-3.0.14.2.15.ebuild
new file mode 100644
index 0000000..82e82dc
--- /dev/null
+++ b/sys-apps/setroubleshoot-plugins/setroubleshoot-plugins-3.0.14.2.15.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit versionator rpm eutils python
+
+MY_PV="$(replace_version_separator 3 -)"
+comp=($(get_all_version_components))
+count=$(get_version_component_count)
+last="$(( 2 * ${count} - 2 ))"
+MY_PV="${MY_PV%${comp[$last]}}"
+MY_PV="${MY_PV}fc${comp[$last]}"
+S="${WORKDIR}/${PN}-${comp[0]}${comp[1]}${comp[2]}${comp[3]}${comp[4]}"
+
+DESCRIPTION="Tool to analyse AVC Messages"
+HOMEPAGE="https://fedorahosted.org/setroubleshoot"
+SRC_URI="mirror://fedora/development/rawhide/source/SRPMS/${PN}-${MY_PV}.src.rpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="selinux"
+
+DEPEND="dev-util/intltool"
+RDEPEND="sys-apps/policycoreutils
+ sys-libs/libselinux"
+
+src_unpack() {
+ srcrpm_unpack
+}
+
+src_configure() {
+ mv -f py-compile py-compile.ori \
+ || die "mv -f py-compile py-compile.orig failed."
+ ln -s $(type -P true) py-compile \
+ || die "ln -s $(type -P true) py-compile failed."
+ econf --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --libexecdir=/usr/$(get_libdir) \
+ --localstatedir=/var \
+ || die "Configure failure"
+}
+
+src_compile() {
+ emake || die "Make failure"
+}
+
+src_install() {
+ make DESTDIR="${D}" install \
+ || die "Install failure"
+
+ rm -rf "${D}/usr/share/doc"
+ dodoc AUTHORS ChangeLog README
+}
+
+pkg_postinst() {
+ PYTHON
+ python_need_rebuild
+ python_mod_optimize /usr/share/setroubleshoot/plugins
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/setroubleshoot/plugins
+}
diff --git a/sys-apps/setroubleshoot/Manifest b/sys-apps/setroubleshoot/Manifest
index f629aeb..501578e 100644
--- a/sys-apps/setroubleshoot/Manifest
+++ b/sys-apps/setroubleshoot/Manifest
@@ -2,13 +2,13 @@
Hash: SHA256
DIST setroubleshoot-3.0.32-1.fc16.src.rpm 1583162 RMD160 1d6edbc7b54c73029338b42becb83f718cbbc0b1 SHA1 a9c20be1ce079d1143f463edbb25b11519bb7451 SHA256 1f527dbcc8799d362279d9f7582f65ca42ae3b7ad4ac28fd489e02c7229afbc2
-EBUILD setroubleshoot-3.0.32.1.16.ebuild 1487 RMD160 6522404a8ade1f5ccffdbad647c74cbcfee36bfb SHA1 1af819772976df083dc116638c1ed87e2436c9cc SHA256 c6e33eea16e2e559d339cf1ba57604f5401db8c3871f6dbdd6c7c947790a3384
+EBUILD setroubleshoot-3.0.32.1.16.ebuild 1625 RMD160 c13bf6443010588667dffd9bcbc2a9dfc10f0aa0 SHA1 afe932e2969bf1507f0e981791c0d872722de07f SHA256 beac279948537c6ebc5d7c8679df7cbb49118f5ac48fd480e1ea4cece2540614
MISC ChangeLog 111 RMD160 39c2220a206759ba8e75fc2d3b3cebf7da78eef8 SHA1 1af887b26112ed43aee6a810bc23d114c9db112a SHA256 394b3b9ac6e645a93ffbe37c1a2ebfa95629adc169215539a7d3ce8a61f53cf7
MISC metadata.xml 260 RMD160 cb2578f6f6e6e46e5ae92dd8a6efaad01a9d869c SHA1 a750ecea19925d6e802e9d79d43f5290e662977f SHA256 93446a91438fa65f110ad12ca91f6e30d22e8b35e09cf4b178c1a6cf5d6e591f
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.17 (GNU/Linux)
-iEYEAREIAAYFAk2pAbYACgkQl5yvQNBFVTXK1gCfbeJRN9X32xKe1IyGfgPSeX3O
-wJEAn27OOYvpa58w8CqVFnkZfhDpnNX2
-=CEXm
+iEYEAREIAAYFAk2qSz8ACgkQl5yvQNBFVTV6HgCfc7RX+ldmmuV9KL4WKvWRRN2q
+c/4AoIYyI/VAjgdIUenVs5YnVQGxs1lG
+=DBCD
-----END PGP SIGNATURE-----
diff --git a/sys-apps/setroubleshoot/setroubleshoot-3.0.32.1.16.ebuild b/sys-apps/setroubleshoot/setroubleshoot-3.0.32.1.16.ebuild
index f43e49f..cd0e1eb 100644
--- a/sys-apps/setroubleshoot/setroubleshoot-3.0.32.1.16.ebuild
+++ b/sys-apps/setroubleshoot/setroubleshoot-3.0.32.1.16.ebuild
@@ -25,7 +25,11 @@ IUSE="selinux"
DEPEND="dev-util/intltool"
RDEPEND="sys-apps/policycoreutils
- sys-libs/libselinux"
+ sys-libs/libselinux
+ sys-apps/dbus
+ x11-libs/gtk+
+ x11-libs/libnotify
+ www-client/htmlview"
src_unpack() {
srcrpm_unpack
@@ -53,14 +57,15 @@ src_install() {
rm -rf "${D}/usr/share/doc"
dodoc AUTHORS ChangeLog README
+ dodir /usr/share/setroubleshoot/plugins
}
pkg_postinst() {
- python_version
+ PYTHON
python_need_rebuild
python_mod_optimize /usr/share/setroubleshoot/plugins
}
pkg_postrm() {
- python_mod_cleanup
+ python_mod_cleanup /usr/share/setroubleshoot/plugins
}