summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2012-06-06 14:47:46 -0400
committerDane Smith <c1pher@gentoo.org>2012-06-06 14:47:46 -0400
commited09a11925db43f27ff9010f6328510aab34fa0b (patch)
tree4909d0df41073f8f08998ad1e65d430a821505c6 /sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild
parentDrop sabnzbd. (diff)
downloadc1pher-ed09a11925db43f27ff9010f6328510aab34fa0b.tar.gz
c1pher-ed09a11925db43f27ff9010f6328510aab34fa0b.tar.bz2
c1pher-ed09a11925db43f27ff9010f6328510aab34fa0b.zip
google-authenticator PAM module.
Diffstat (limited to 'sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild')
-rw-r--r--sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild b/sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild
new file mode 100644
index 0000000..2c67ddf
--- /dev/null
+++ b/sys-auth/libpam-google-authenticator/libpam-google-authenticator-1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+inherit pam
+
+DESCRIPTION="Google Authentiator PAM plugin"
+HOMEPAGE="http://code.google.com/p/google-authenticator/"
+SRC_URI="http://google-authenticator.googlecode.com/files/${P}-source.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/pam"
+RDEPEND="${DEPEND}"
+
+src_prepare(){
+ epatch "${FILESDIR}/makefile.patch"
+}
+
+src_install(){
+ insinto $(getpam_mod_dir)
+ doins pam_google_authenticator.so
+ dobin google-authenticator
+
+ dodoc README
+}
+
+pkg_postinst(){
+ elog "For setup information check the installed README"
+}