summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/indefero/indefero-1.2.ebuild')
-rw-r--r--www-apps/indefero/indefero-1.2.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/www-apps/indefero/indefero-1.2.ebuild b/www-apps/indefero/indefero-1.2.ebuild
index 5a698a4..20984d6 100644
--- a/www-apps/indefero/indefero-1.2.ebuild
+++ b/www-apps/indefero/indefero-1.2.ebuild
@@ -23,6 +23,8 @@ S="${WORKDIR}/${PN}"
src_prepare(){
#Expect pluf to be installed in the normal location.
epatch "${FILESDIR}/${PN}-gentoo-pluf.diff"
+ cp "${FILESDIR}/dbsetup.sh" scripts/
+ cp "${FILESDIR}/bootstrap.php" www/
}
src_install(){
@@ -36,7 +38,11 @@ src_install(){
cp -R . "${D}/${MY_HTDOCSDIR}"
webapp_configfile "${MY_HTDOCSDIR}/src/IDF/conf/idf.php"
- #Write a postinstall doc
- #webapp_postinstall_txt en "${FILESDIR}/postinstall-en-${PV}.txt"
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en-${PV}.txt"
webapp_src_install
}
+
+pkg_postinst(){
+ elog "The postinstall document contains all of the information"
+ elog "needed to get ${PN} running."
+}