summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2013-09-13 10:26:23 -0700
committerPatrick McLean <chutzpah@gentoo.org>2013-09-13 10:26:23 -0700
commit9f3f73370f19f74cca2776ba79597a6ad8091bbd (patch)
treea9168b7b301b556f5b52813e7322f3fcfee985d5
parentremove RESTRICT=mirror (diff)
downloadchutzpah-9f3f73370f19f74cca2776ba79597a6ad8091bbd.tar.gz
chutzpah-9f3f73370f19f74cca2776ba79597a6ad8091bbd.tar.bz2
chutzpah-9f3f73370f19f74cca2776ba79597a6ad8091bbd.zip
Add a 9999 ebuild for app-vim/fugitive to my overlay
-rw-r--r--app-vim/fugitive/Manifest1
-rw-r--r--app-vim/fugitive/fugitive-9999.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-vim/fugitive/Manifest b/app-vim/fugitive/Manifest
new file mode 100644
index 0000000..2300978
--- /dev/null
+++ b/app-vim/fugitive/Manifest
@@ -0,0 +1 @@
+EBUILD fugitive-9999.ebuild 739 SHA256 5cca18dd1da78db96804c3486a3522a841e6f285b0757effe392f6ce112c096d SHA512 b2228e79761d18628c55eaa608029c6b7555275b7300edd372515e062d766bf093b1be6cb2ebe8a740cf4020cccd77484b0c8535dda14e72523dd562e151ba6f WHIRLPOOL 7d1ca08e520d07b6c07587460a5059e02fff8bcf47e522ec71394ceed5618a8f355e6b7d4cad77150894741a3ddf3b97a501451e5cf0c6d4e6b859467add03c6
diff --git a/app-vim/fugitive/fugitive-9999.ebuild b/app-vim/fugitive/fugitive-9999.ebuild
new file mode 100644
index 0000000..392fb45
--- /dev/null
+++ b/app-vim/fugitive/fugitive-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/fugitive/fugitive-1.2.ebuild,v 1.3 2012/11/27 22:34:33 ulm Exp $
+
+EAPI=5
+VIM_PLUGIN_VIM_VERSION="7.3"
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: a git wrapper for vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2975"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tpope/vim-fugitive.git"
+else
+ SRC_URI="http://www.vim.org/scripts/download_script.php?src_id=15542 -> ${P}.zip"
+ KEYWORDS="~amd64 ~x86 ~ppc-macos"
+ S="${WORKDIR}"
+fi
+
+LICENSE="vim"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="fugitive.txt"
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-vcs/git"