summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/nginx/nginx-1.1.18.ebuild')
-rw-r--r--www-servers/nginx/nginx-1.1.18.ebuild24
1 files changed, 22 insertions, 2 deletions
diff --git a/www-servers/nginx/nginx-1.1.18.ebuild b/www-servers/nginx/nginx-1.1.18.ebuild
index 9c7793f..82c0575 100644
--- a/www-servers/nginx/nginx-1.1.18.ebuild
+++ b/www-servers/nginx/nginx-1.1.18.ebuild
@@ -50,6 +50,14 @@ HTTP_SLOWFS_CACHE_MODULE_PV="1.8"
HTTP_SLOWFS_CACHE_MODULE_P="ngx_slowfs_cache-${HTTP_SLOWFS_CACHE_MODULE_PV}"
HTTP_SLOWFS_CACHE_MODULE_URI="http://labs.frickle.com/files/${HTTP_SLOWFS_CACHE_MODULE_P}.tar.gz"
+# http_fancyindex_module (http://wiki.nginx.org/NgxFancyIndex, as-is license)
+HTTP_FANCYINDEX_MODULE_PV="0.3.1"
+HTTP_FANCYINDEX_MODULE_PN="ngx-fancyindex"
+# gitorious names the tarbell oddly, hence PNPN
+HTTP_FANCYINDEX_MODULE_PNPN="ngx-fancyindex-ngx-fancyindex"
+HTTP_FANCYINDEX_MODULE_P="${HTTP_FANCYINDEX_MODULE_PN}-${HTTP_FANCYINDEX_MODULE_PV}"
+HTTP_FANCYINDEX_MODULE_URI="http://gitorious.org/${HTTP_FANCYINDEX_MODULE_PN}/${HTTP_FANCYINDEX_MODULE_PN}/archive-tarball/v${HTTP_FANCYINDEX_MODULE_PV}"
+
inherit eutils ssl-cert toolchain-funcs perl-module flag-o-matic
DESCRIPTION="Robust, small and high performance http and reverse proxy server"
@@ -60,7 +68,8 @@ SRC_URI="http://nginx.org/download/${P}.tar.gz
nginx_modules_http_push? ( ${HTTP_PUSH_MODULE_URI} )
nginx_modules_http_cache_purge? ( ${HTTP_CACHE_PURGE_MODULE_URI} )
nginx_modules_http_upload? ( ${HTTP_UPLOAD_MODULE_URI} )
- nginx_modules_http_slowfs_cache? ( ${HTTP_SLOWFS_CACHE_MODULE_URI} )"
+ nginx_modules_http_slowfs_cache? ( ${HTTP_SLOWFS_CACHE_MODULE_URI} )
+ nginx_modules_http_fancyindex? ( ${HTTP_FANCYINDEX_MODULE_URI} -> ${HTTP_FANCYINDEX_MODULE_P}.tar.gz )"
LICENSE="as-is BSD BSD-2 GPL-2 MIT"
SLOT="0"
@@ -79,7 +88,8 @@ NGINX_MODULES_3RD="
http_push
http_cache_purge
http_upload
- http_slowfs_cache"
+ http_slowfs_cache
+ http_fancyindex"
IUSE="aio debug +http +http-cache ipv6 libatomic +pcre pcre-jit ssl vim-syntax"
@@ -226,6 +236,11 @@ src_configure() {
myconf+=" --add-module=${WORKDIR}/${HTTP_SLOWFS_CACHE_MODULE_P}"
fi
+ if use nginx_modules_http_fancyindex; then
+ http_enabled=1
+ myconf+=" --add-module=${WORKDIR}/${HTTP_FANCYINDEX_MODULE_PNPN}"
+ fi
+
if use http || use http-cache; then
http_enabled=1
fi
@@ -334,6 +349,11 @@ src_install() {
docinto ${HTTP_SLOWFS_CACHE_MODULE_P}
dodoc "${WORKDIR}"/${HTTP_SLOWFS_CACHE_MODULE_P}/{CHANGES,README.md}
fi
+
+ if use nginx_modules_http_fancyindex; then
+ docinto ${HTTP_FANCYINDEX_MODULE_P}
+ dodoc "${WORKDIR}"/${HTTP_FANCYINDEX_MODULE_PNPN}/README.rst
+ fi
}
pkg_postinst() {