summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/mathematica/mathematica-10.3.1-r1.ebuild')
-rw-r--r--sci-mathematics/mathematica/mathematica-10.3.1-r1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sci-mathematics/mathematica/mathematica-10.3.1-r1.ebuild b/sci-mathematics/mathematica/mathematica-10.3.1-r1.ebuild
index 4f78ea7..5d21950 100644
--- a/sci-mathematics/mathematica/mathematica-10.3.1-r1.ebuild
+++ b/sci-mathematics/mathematica/mathematica-10.3.1-r1.ebuild
@@ -49,13 +49,15 @@ src_install() {
# install wrappers instead
for name in ${M_BINARIES} ; do
+ einfo "Generating wrapper for ${name}"
echo '#!/bin/sh' >> "${T}/${name}"
echo "LD_PRELOAD=/usr/$(get_libdir)/libfreetype.so.6:/lib/libz.so.1 /opt/Wolfram/${MPN}/${MPV}/Executables/${name} \$*" \
>> "${T}/${name}"
dobin "${T}/${name}"
done
for name in ${M_BINARIES} ; do
- dosym /opt/bin/${name} ../../usr/bin/${name}
+ einfo "Symlinking ${name} to /opt/bin"
+ dosym ../../usr/bin/${name} /opt/bin/${name}
done
# fix some embedded paths and install desktop files