summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/drizzt-scripts/files/fix_overlay')
-rw-r--r--app-portage/drizzt-scripts/files/fix_overlay8
1 files changed, 4 insertions, 4 deletions
diff --git a/app-portage/drizzt-scripts/files/fix_overlay b/app-portage/drizzt-scripts/files/fix_overlay
index 286579a..bf53ae0 100644
--- a/app-portage/drizzt-scripts/files/fix_overlay
+++ b/app-portage/drizzt-scripts/files/fix_overlay
@@ -7,6 +7,10 @@ if [[ ! -f "${1:-.}"/profiles/repo_name ]]; then
exit 1
fi
+ebegin "Generating categories"
+find "${1:-.}" -maxdepth 1 -mindepth 1 -type d -not -name licenses -not -name profiles -not -name '.*' | sed 's:^.*/::' | sort > "${1:-.}"/profiles/categories
+eend
+
ebegin "Generating thirdpartymirrors"
if type -p paludis &>/dev/null; then
find "${1:-.}" -name '*.ebuild' | sed 's|^\./\([^/]*\)/[^/]*\(/[^/]*\).ebuild$|=\1\2::'"$(<"${1:-.}"/profiles/repo_name)"'|' | xargs paludis -qM | grep '^[[:space:]]*SRC_URI: ' | sed -e 's|mirror://[^ ]*|\n&\n|g' | sed -ne '/mirror/s|mirror://\([^/]*\)[^ ]*|\1|gp' | sort -u | xargs -i% grep '^%[[:space:]]' "$(paludis --configuration-variable gentoo location)"/profiles/thirdpartymirrors > "${1:-.}"/profiles/thirdpartymirrors
@@ -15,10 +19,6 @@ else
fi
eend
-ebegin "Generating categories"
-find "${1:-.}" -maxdepth 1 -mindepth 1 -type d -not -name licenses -not -name profiles -not -name '.*' | sed 's:^.*/::' | sort > "${1:-.}"/profiles/categories
-eend
-
ebegin "Generating arch.list"
if type -p paludis &>/dev/null; then
find "${1:-.}" -name '*.ebuild' | sed 's|^\./\([^/]*\)/[^/]*\(/[^/]*\).ebuild$|=\1\2::'"$(<"${1:-.}"/profiles/repo_name)"'|' | xargs paludis -qM | grep '^[[:space:]]*KEYWORDS: ' | cut -d : -f 2- | sed -e 's/-\*//g' -e 's/\([[:space:]]\)[~-]/\1/g' -e 's/^[[:space:]]*//' -e 's/ /\n/g' | sort -u > "${1:-.}"/profiles/arch.list