summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-11-03 22:38:30 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2015-11-03 23:47:26 +0100
commit43f0d6a6c87867070cea8508ca40fd78bfc0895e (patch)
treea282b32950a41e5deb6187d7c7d0c0ff3a83ed1f
parentdev-go/gls: initial ebuild (diff)
downloadeva-43f0d6a6.tar.gz
eva-43f0d6a6.tar.bz2
eva-43f0d6a6.zip
dev-go/goconvey: initial ebuild
-rw-r--r--dev-go/goconvey/Manifest2
-rw-r--r--dev-go/goconvey/goconvey-1.5.0.ebuild19
-rw-r--r--dev-go/goconvey/goconvey-1.5.0_p20141231.ebuild20
-rw-r--r--dev-go/goconvey/metadata.xml11
4 files changed, 52 insertions, 0 deletions
diff --git a/dev-go/goconvey/Manifest b/dev-go/goconvey/Manifest
new file mode 100644
index 0000000..ed14436
--- /dev/null
+++ b/dev-go/goconvey/Manifest
@@ -0,0 +1,2 @@
+DIST goconvey-1.5.0.tar.gz 234457 SHA256 c4af6a1a63a49568fcd512cbc017c7a7319fe4259d4eb0929be44db45831693c SHA512 10bf44f09a90c7f88a15ad3aad8c8782d01b55c3fae4f9da4e16cd143eddf964b90af7017bfa8df8a67990f378eb6eda2eb42ad5398483432a011667a281ee5f WHIRLPOOL 921aa3f223c88818002fd8c0515866d0db2773099bba77d2201699f65dbf3bcc5331877dcfcf5b3ddafb46184b798b3f45802277b4768d3bfc379e11f8c9d811
+DIST goconvey-1.5.0_p20141231.tar.gz 1266550 SHA256 431c24df2c0ca3c6ccfc62b1e51e197917fda1d1a7967f91487d7eff0bb1ec3c SHA512 d121f6bc1cffd55fa8fe58cce8b9e6062aa4e7102f1b1c70a32a3068606409b6d4bc76f91f36be39bf58ee47effedaa0f200410b64aa2ea1ce20d2a03167306b WHIRLPOOL 323c30df359d7237f0c256bace1569cafb0de05ad93ed175d5c18bfa62a419417296bcc17b1f0aaf584aaf8057f346d42b76e60e03d3a1a0d273fe4883813ce9
diff --git a/dev-go/goconvey/goconvey-1.5.0.ebuild b/dev-go/goconvey/goconvey-1.5.0.ebuild
new file mode 100644
index 0000000..9071c4f
--- /dev/null
+++ b/dev-go/goconvey/goconvey-1.5.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+EGO_PN="github.com/smartystreets/goconvey"
+
+inherit golang-build golang-vcs-snapshot
+
+DESCRIPTION="Write behavioral tests in Go."
+HOMEPAGE="https://github.com/smartystreets/goconvey"
+SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=""
+DEPEND=""
diff --git a/dev-go/goconvey/goconvey-1.5.0_p20141231.ebuild b/dev-go/goconvey/goconvey-1.5.0_p20141231.ebuild
new file mode 100644
index 0000000..28b573d
--- /dev/null
+++ b/dev-go/goconvey/goconvey-1.5.0_p20141231.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+EGO_PN=github.com/smartystreets/goconvey
+EGIT_COMMIT=fbc0a1c8
+
+inherit golang-build golang-vcs-snapshot
+
+DESCRIPTION="Write behavioral tests in Go."
+HOMEPAGE="https://github.com/smartystreets/goconvey"
+SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=""
+DEPEND=""
diff --git a/dev-go/goconvey/metadata.xml b/dev-go/goconvey/metadata.xml
new file mode 100644
index 0000000..9cecb1d
--- /dev/null
+++ b/dev-go/goconvey/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>eva@gentoo.org</email>
+ <name>Gilles Dartiguelongue</name>
+</maintainer>
+<upstream>
+ <remote-id type="github">smartystreets/goconvey</remote-id>
+</upstream>
+</pkgmetadata>