summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/go-sqlite3/go-sqlite3-1.1.0.ebuild')
-rw-r--r--dev-go/go-sqlite3/go-sqlite3-1.1.0.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-go/go-sqlite3/go-sqlite3-1.1.0.ebuild b/dev-go/go-sqlite3/go-sqlite3-1.1.0.ebuild
deleted file mode 100644
index da47c33..0000000
--- a/dev-go/go-sqlite3/go-sqlite3-1.1.0.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-EGO_PN="github.com/mattn/go-sqlite3"
-
-inherit golang-build
-
-DESCRIPTION="sqlite3 driver for go that using database/sql"
-HOMEPAGE="https://github.com/mattn/go-sqlite3"
-SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="icu"
-
-RDEPEND=""
-DEPEND="
- dev-db/sqlite:3[icu?]
-"
-
-src_prepare() {
- mkdir -p "${WORKDIR}"/${PN}/src/${EGO_PN%/*} || die
- mv "${S}" "${WORKDIR}"/${PN}/src/${EGO_PN} || die
- mv "${WORKDIR}"/${PN} "${S}" || die
-}
-
-src_compile() {
- local myconf=( libsqlite3 linux )
- if use icu ; then
- myconf+=( icu )
- fi
- golang-build_src_compile --tags "${myconf[$@]}"
-}