summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2024-02-21 19:35:18 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2024-02-21 19:35:18 +0100
commit31a22b909d8c4a2977b236bdd5d979730234bf18 (patch)
treea4b48a7ae34c22ec97f07182b3b5a4a043ebce7d
parentdropped scripts (diff)
downloadfordfrog-31a22b909d8c4a2977b236bdd5d979730234bf18.tar.gz
fordfrog-31a22b909d8c4a2977b236bdd5d979730234bf18.tar.bz2
fordfrog-31a22b909d8c4a2977b236bdd5d979730234bf18.zip
dev-util/netbeans-standalone: bump to 21
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--dev-util/netbeans-standalone/Manifest2
-rw-r--r--dev-util/netbeans-standalone/netbeans-standalone-21.ebuild118
2 files changed, 120 insertions, 0 deletions
diff --git a/dev-util/netbeans-standalone/Manifest b/dev-util/netbeans-standalone/Manifest
index 25cbf60a3..f7ab935e3 100644
--- a/dev-util/netbeans-standalone/Manifest
+++ b/dev-util/netbeans-standalone/Manifest
@@ -1,5 +1,7 @@
AUX fix-private-debugger-access.patch 1621 BLAKE2B f3124edee73f31445a6093129a1de8a614991115dc5df39b794fbaad09ec64f7b7114faf4057906da4a0b5a17911e30ab774e6e49e14a3ee46dccbed13735f57 SHA512 b2fe14770733c5b9c53f18fdc5c001add901ff1b28755ae960ffb72ae6106fd930a832f2857e00e96c88f58d3339223b0321ee6474507b6c3c3b3739a807df19
DIST netbeans-20-source.zip 149519565 BLAKE2B 12958288ca89e2c2ce29e76f82f31afebe5c8000aba7d47aab8c5dd7435b1d3b53c33eaefd5dc559aaf122f4bc3e6cd429924686b111dce4f952e0b24ac65d96 SHA512 e795875918022541354213b03d7c4515db81c384f43d0b87029666583064e3093ca1a6ebe8f6ffa633c62d02a551be8df52703dfefb830efb8654558ddec5f28
+DIST netbeans-21-source.zip 151092333 BLAKE2B 27e3e73000a3ccbd396bea6e7484d919e0d90a7afc5bc8c3b737f998c41dae2fafc115311ea59ea98ed787866f0ea32455906a493e7ff2372ce725969775a040 SHA512 60533839fe9513e7e4b6f0f8ced77f076a28b89aa3fcc4ea4487a633263d906b8c32b11e8ad4470a820c3a66e795eeb42fb0eda10645414424739a408312bfe5
EBUILD netbeans-standalone-20.ebuild 5306 BLAKE2B ed64592a08e96889c521df389158abe908ca6deba3a743eb17312ac0652216083928f3a55341966eef85845854afaadee7b3e5342be2d756d3af0436adcdcec1 SHA512 8db722589ae6b13f554a4683af097770f0d4e237ff1a3145525589d5a2801e177fa3491489ad961eb49e3ce0ec96e806066c1a3f0c09a0c452499b013d490474
+EBUILD netbeans-standalone-21.ebuild 5306 BLAKE2B ed64592a08e96889c521df389158abe908ca6deba3a743eb17312ac0652216083928f3a55341966eef85845854afaadee7b3e5342be2d756d3af0436adcdcec1 SHA512 8db722589ae6b13f554a4683af097770f0d4e237ff1a3145525589d5a2801e177fa3491489ad961eb49e3ce0ec96e806066c1a3f0c09a0c452499b013d490474
EBUILD netbeans-standalone-9999.ebuild 5162 BLAKE2B a948e6a720783af503ad252ec2c1fc2bf1a607a7fd2ceeea0d536031f812278ff755903dc0bc00b0431491026d69f9816a80a76ab3f32ec7d51e571d49343c9e SHA512 007fb456ccc98af81c3a1b7135f6c5e49945dca68ce7cd810a5c0af5cfa365975afd7bcd772152eff414bdada562a3957a2f785248ce638fa4d76a7591bb36e5
MISC metadata.xml 338 BLAKE2B 25922d9e4c7c4cd111db8b96e1dcb3cf026d9262b9d0861a4bcd49009303fc8535afd370e301d3f51f3127516c3b2561d6d6f56de0433a835f85fa15d1ab5012 SHA512 b7525dac3a4947550c33f096550e82644ed8a790e915a66ee627f81727f58fcbf0a055f298f8b45ee8d08da747fec79a8276a96ce0dcc43b847341166fbea4e9
diff --git a/dev-util/netbeans-standalone/netbeans-standalone-21.ebuild b/dev-util/netbeans-standalone/netbeans-standalone-21.ebuild
new file mode 100644
index 000000000..d526245a9
--- /dev/null
+++ b/dev-util/netbeans-standalone/netbeans-standalone-21.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ANT_TASKS="ant-apache-bsf"
+
+if [ ${PV} = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/apache/netbeans.git"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="mirror://apache/netbeans/netbeans/${PV}/netbeans-${PV}-source.zip"
+ S="${WORKDIR}"
+fi
+
+inherit java-pkg-2 java-ant-2 desktop xdg $([[ ${PV} = "9999" ]] && echo git-r3)
+
+DESCRIPTION="Apache Netbeans IDE"
+HOMEPAGE="https://netbeans.apache.org/"
+LICENSE="Apache-2.0"
+SLOT="$(ver_cut 1-1)"
+IUSE=""
+
+DEPEND=">=virtual/jdk-11:*"
+RDEPEND=">=virtual/jdk-11"
+
+JAVA_PKG_BSFIX="off"
+INSTALL_DIR=/usr/share/${PN}-${SLOT}
+
+pkg_pretend() {
+ if has network-sandbox ${FEATURES}; then
+ eerror
+ eerror "Netbeans downloads a lot of dependencies during the build"
+ eerror "process, so you need to disable network-sandbox feature"
+ eerror "to make this ebuild proceed (FEATURES=-network-sandbox)."
+ eerror "You can also use package.env to disable this feature"
+ eerror "for the package, see:"
+ eerror
+ eerror " https://wiki.gentoo.org/wiki//etc/portage/package.env"
+ eerror
+ die "network-sandbox is enabled, disable it to proceed";
+ fi
+}
+
+src_prepare() {
+ default
+
+ # remove rust from the full list as there is no cluster provided in the tarball
+ sed -i /nb.cluster.rust,/d nbbuild/cluster.properties || die
+}
+
+src_compile() {
+ GRADLE_USER_HOME="${HOME}/.gradle" eant -Dcluster.config=full -Dpermit.jdk9.builds=true -Dbinaries.cache="${S}"/.hgexternalcache || die "Failed to compile"
+}
+
+QA_PREBUILT="
+ usr/share/netbeans-standalone-11/ide/bin/nativeexecution/Linux-x86_64/process_start
+ usr/share/netbeans-standalone-11/ide/bin/nativeexecution/Linux-x86_64/stat
+ usr/share/netbeans-standalone-11/ide/bin/nativeexecution/Linux-x86_64/pty_open
+ usr/share/netbeans-standalone-11/ide/bin/nativeexecution/Linux-x86_64/sigqueue
+ usr/share/netbeans-standalone-11/ide/bin/nativeexecution/Linux-x86_64/unbuffer.so
+ usr/share/netbeans-standalone-11/ide/bin/nativeexecution/Linux-x86_64/killall
+ usr/share/netbeans-standalone-11/ide/bin/nativeexecution/Linux-x86_64/pty
+ usr/share/netbeans-standalone-11/profiler/lib/deployed/jdk16/linux-amd64/libprofilerinterface.so
+ usr/share/netbeans-standalone-11/profiler/lib/deployed/jdk15/linux-amd64/libprofilerinterface.so
+ usr/share/netbeans-standalone-11/profiler/lib/deployed/cvm/linux/libprofilerinterface_g.so
+ usr/share/netbeans-standalone-11/profiler/lib/deployed/cvm/linux/libprofilerinterface.so
+ usr/share/netbeans-standalone-11/platform/modules/lib/amd64/linux/libjnidispatch-440.so
+ usr/share/netbeans-standalone-11/profiler/lib/deployed/jdk16/linux-amd64/libprofilerinterface.so
+"
+
+src_install() {
+ pushd nbbuild/netbeans >/dev/null || die
+
+ insinto ${INSTALL_DIR}
+ doins -r .
+
+ rm -fr "${ED}"/${INSTALL_DIR}/ide/bin/nativeexecution/{Linux-{sparc_64,x86},MacOSX-{x86_64,x86},SunOS-{sparc,sparc_64,x86,x86_64},Windows-{x86,x86_64}} || die "Failed to remove unused binaries"
+ find "${ED}"/${INSTALL_DIR}/ \( -name *.exe -o -name *.cmd -o -name *.bat \) -type f -exec rm {} + || die "Failed to remove unused binaries"
+ rm -fr "${ED}"/${INSTALL_DIR}/profiler/lib/deployed/jdk15/{hpux-pa_risc2.0{,w},linux,mac,solaris-{amd64,i386,sparc{,v9}},windows{,-amd64}} || die "Failed to remove unused libraries"
+ rm -fr "${ED}"/${INSTALL_DIR}/profiler/lib/deployed/jdk16/{hpux-pa_risc2.0{,w},linux{,-arm,-arm-vfp-hflt},mac,solaris-{amd64,i386,sparc{,v9}},windows{,-amd64}} || die "Failed to remove unused libraries"
+ rm -fr "${ED}"/${INSTALL_DIR}/profiler/lib/deployed/cvm/windows || die "Failed to remove unused libraries"
+ rm -fr "${ED}"/${INSTALL_DIR}/platform/modules/lib/{i386,x86} || die "Failed to remove unused libraries"
+ find "${ED}"/${INSTALL_DIR}/ -name *.dll -type f -exec rm {} + || die "Failed to remove unused libraries"
+
+ find "${ED}/${INSTALL_DIR}" -name "*.so*" -type f -exec chmod +x {} \; || die "Change .so permission failed"
+ exeinto ${INSTALL_DIR}/ide/bin/nativeexecution/Linux-x86_64/
+ doexe ide/bin/nativeexecution/Linux-x86_64/{process_start,stat,pty_open,sigqueue,killall,pty}
+ exeinto ${INSTALL_DIR}/java/maven/bin
+ doexe java/maven/bin/mvn{,Debug,yjp}
+ exeinto ${INSTALL_DIR}/extide/ant/bin
+ doexe extide/ant/bin/{ant{,Run,Run.pl},complete-ant-cmd.pl,runant.{pl,py}}
+
+ dodoc DEPENDENCIES NOTICE
+ dosym ${INSTALL_DIR}/bin/netbeans /usr/bin/${PN}-${SLOT}
+ fperms 755 ${INSTALL_DIR}/bin/netbeans
+
+ insinto /etc/${PN}-${SLOT}
+ doins etc/*
+ rm -fr "${ED}"/${INSTALL_DIR}/etc
+ dosym ../../../../etc/${PN}-${SLOT} ${INSTALL_DIR}/etc
+ sed -i -e "s/#netbeans_jdkhome.*/netbeans_jdkhome=\$\(java-config -O\)/g" "${ED}"/etc/${PN}-${SLOT}/netbeans.conf || die "Failed to set set Netbeans JDK home"
+
+ if [[ -e "${ED}"/${INSTALL_DIR}/bin/netbeans ]]; then
+ sed -i -e "s:\"\$progdir\"/../etc/:/etc/${PN}-${SLOT}/:" "${ED}"/${INSTALL_DIR}/bin/netbeans
+ sed -i -e "s:\"\${userdir}\"/etc/:/etc/${PN}-${SLOT}/:" "${ED}"/${INSTALL_DIR}/bin/netbeans
+ fi
+
+ dodir /usr/share/icons/hicolor/32x32/apps
+ dosym ${INSTALL_DIR}/nb/netbeans.png /usr/share/icons/hicolor/32x32/apps/${PN}-${SLOT}.png
+
+ popd >/dev/null || die
+
+ make_desktop_entry ${PN}-${SLOT} "Netbeans ${PV}" ${PN}-${SLOT} Development
+
+ mkdir -p "${ED}"/${INSTALL_DIR}/nb/config || die
+ echo "NBGNT" > "${ED}"/${INSTALL_DIR}/nb/config/productid || die
+}