summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2019-06-08 10:02:51 +0200
committerHans de Graaff <hans@degraaff.org>2019-06-08 10:02:51 +0200
commitd9860294a2e80f44c6cec53494977189d43e4215 (patch)
tree164ff7a31eaf94cbe318374134d8c6dd749c71de /app-emacs/flycheck
parentdev-ruby/active_model_otp: add 2.0.1 (diff)
downloadgraaff-d9860294a2e80f44c6cec53494977189d43e4215.tar.gz
graaff-d9860294a2e80f44c6cec53494977189d43e4215.tar.bz2
graaff-d9860294a2e80f44c6cec53494977189d43e4215.zip
app-emacs/flycheck: hardcode version number
We don't install via Melpa so we can't determine the version number using package.el. Hard-code it in since it is required to enable some checkers and to make things like flycheck-verify-setup work. Don't use PV at the moment since we use an upstream snapshot. Signed-off-by: Hans de Graaff <hans@degraaff.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'app-emacs/flycheck')
-rw-r--r--app-emacs/flycheck/flycheck-31_p20190503-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-emacs/flycheck/flycheck-31_p20190503-r1.ebuild b/app-emacs/flycheck/flycheck-31_p20190503-r1.ebuild
new file mode 100644
index 00000000..1c6f86b0
--- /dev/null
+++ b/app-emacs/flycheck/flycheck-31_p20190503-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+COMMIT=47174a12fd84a685f36019632838c73b4813b66d
+FLYCHECK_VERSION=32
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="On the fly syntax checking for GNU Emacs"
+HOMEPAGE="https://github.com/flycheck/flycheck"
+SRC_URI="https://github.com/flycheck/flycheck/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND=">=app-emacs/dash-2.12.1"
+DEPEND=${RDEPEND}
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+# Requires unpackaged dependencies, e.g. buttercup
+RESTRICT="test"
+
+src_prepare() {
+ # Patch in the version number since we don't install via melpa.
+ sed -i -e "s/(pkg-info-version-info 'flycheck)/"${FLYCHECK_VERSION}"/" flycheck.el || die
+
+ sed -i -e '/^CASK/ s/^/#/' Makefile || die
+ eapply_user
+}