summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2023-11-24 07:52:06 +0100
committerHans de Graaff <hans@degraaff.org>2023-11-24 07:52:06 +0100
commitcfbd9c55e75973145cf8035b59bd7ea7ef42b33a (patch)
treedd4676e87ddf035cdaafe254d149061f2e5d00a5 /app-emacs
parentdev-ruby/active_storage_validations: add 1.1.3 (diff)
downloadgraaff-cfbd9c55e75973145cf8035b59bd7ea7ef42b33a.tar.gz
graaff-cfbd9c55e75973145cf8035b59bd7ea7ef42b33a.tar.bz2
graaff-cfbd9c55e75973145cf8035b59bd7ea7ef42b33a.zip
app-emacs/x509-mode: new package, add 0.20230814
Signed-off-by: Hans de Graaff <hans@degraaff.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/x509-mode/Manifest1
-rw-r--r--app-emacs/x509-mode/files/50x509-mode-gentoo.el15
-rw-r--r--app-emacs/x509-mode/metadata.xml8
-rw-r--r--app-emacs/x509-mode/x509-mode-0.20230814.ebuild27
4 files changed, 51 insertions, 0 deletions
diff --git a/app-emacs/x509-mode/Manifest b/app-emacs/x509-mode/Manifest
new file mode 100644
index 00000000..c31c16ba
--- /dev/null
+++ b/app-emacs/x509-mode/Manifest
@@ -0,0 +1 @@
+DIST x509-mode-0.20230814.tar.gz 551710 BLAKE2B 960d70a4ce300bf463eb968d45b2e6a908b78cf6d89a476506a26e597b688d1182ba7409f5e1266d09a69cf5b8ba75d80c2f6f40e48c3d14dbfd473f9cce8f48 SHA512 6781a22dd31ffa39af8ee5d2135ae0fafe48ef4b177597ec007edc6c5f874890c571064a27327401e8f5e22167a1b3bdf062304cf86fb9e9514682a012c1fa44
diff --git a/app-emacs/x509-mode/files/50x509-mode-gentoo.el b/app-emacs/x509-mode/files/50x509-mode-gentoo.el
new file mode 100644
index 00000000..0f41a792
--- /dev/null
+++ b/app-emacs/x509-mode/files/50x509-mode-gentoo.el
@@ -0,0 +1,15 @@
+
+;;; x509-mode site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'x509-mode "x509-mode" "Major mode for displaying OpenSSL output." t)
+(autoload 'x509-viewcert "x509-mode" "Parse current buffer as a certificate file." t)
+(autoload 'x509-viewreq "x509-mode" "Parse current buffer as a certificate request file." t)
+(autoload 'x509-viewcrl "x509-mode" "Parse current buffer as a CRL file." t)
+(autoload 'x509-viewpkcs7 "x509-mode" "Parse current buffer as a PKCS#7 file." t)
+(autoload 'x509-viewdh "x509-mode" "Parse current buffer as a DH-parameter file." t)
+(autoload 'x509-viewkey "x509-mode" "Display x509 private key using the OpenSSL pkey command." t)
+(autoload 'x509-viewpublickey "x509-mode" "Display x509 public key using the OpenSSL pkey command." t)
+(autoload 'x509-dwim "x509-mode" "Guess the type of object and call the corresponding view-function." t)
+(autoload 'x509-viewasn1 "x509-mode" "Parse current buffer as ASN.1." t)
diff --git a/app-emacs/x509-mode/metadata.xml b/app-emacs/x509-mode/metadata.xml
new file mode 100644
index 00000000..f514b430
--- /dev/null
+++ b/app-emacs/x509-mode/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version = '1.0' encoding = 'UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person"><email>graaff@gentoo.org</email></maintainer>
+ <upstream>
+ <remote-id type="github">jobbflykt/x509-mode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/x509-mode/x509-mode-0.20230814.ebuild b/app-emacs/x509-mode/x509-mode-0.20230814.ebuild
new file mode 100644
index 00000000..d8eb2049
--- /dev/null
+++ b/app-emacs/x509-mode/x509-mode-0.20230814.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+COMMIT=57395a72087875108245f384acd9327db8b59abb
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="View certificates and CRLs using OpenSSL in Emacs"
+HOMEPAGE="https://github.com/jobbflykt/x509-mode"
+SRC_URI="https://github.com/jobbflykt/x509-mode/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/x509-mode-${COMMIT}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+SITEFILE="50${PN}-gentoo.el"
+
+DOCS="README.md"
+
+RDEPEND="dev-libs/openssl"
+
+# Tries to download elpa data
+RESTRICT="test"