summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2020-01-26 10:58:16 +0100
committerHans de Graaff <hans@degraaff.org>2020-01-26 10:58:16 +0100
commitbc3269c9f767bacf4b2c506105320600c4efafef (patch)
tree0cecf7e93ac308857935f0ed38e3a0ced09d6bf1 /dev-python
parentdev-ruby/unicode-display_width: add 1.6.1 (diff)
downloadgraaff-bc3269c9f767bacf4b2c506105320600c4efafef.tar.gz
graaff-bc3269c9f767bacf4b2c506105320600c4efafef.tar.bz2
graaff-bc3269c9f767bacf4b2c506105320600c4efafef.zip
dev-python/rbintegrations: add 1.0.1
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Hans de Graaff <hans@degraaff.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/rbintegrations/Manifest1
-rw-r--r--dev-python/rbintegrations/rbintegrations-1.0.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/rbintegrations/Manifest b/dev-python/rbintegrations/Manifest
index 084b8d1a..d77c4327 100644
--- a/dev-python/rbintegrations/Manifest
+++ b/dev-python/rbintegrations/Manifest
@@ -1 +1,2 @@
+DIST rbintegrations-1.0.1.tar.gz 144686 BLAKE2B ad00c4b736165a3366533539e593f6ac209b84a91e4ad1bc14890caf17b633b621e8b70f3766c1c0f0f541b66d57a813b26bb17cf084b7e52028795f020e95cb SHA512 e383535429a28fbd095fba68d1e0bb660ccf7506ae19468c7f244adb180d42d83d0b538a8c381c7fedbe543e4bf3b469e2e984e94068bf5c165c263f73652be2
DIST rbintegrations-1.0.tar.gz 144525 BLAKE2B 2b137c8259648e19fac3059ec272d25c876754cf8a2c9e6e6a409f736254ab959a680089f685526945856d213b86dbe11b36441f56a2c4d7a3133f9319fa9092 SHA512 7daf1fd5e5c46a9c676ab9706651a83ddb459a2f70520b34a52ce481ec10b8a085989d87471f851f585eac425ec6cc89e21ab6e11d675264314e305e76bf6e28
diff --git a/dev-python/rbintegrations/rbintegrations-1.0.1.ebuild b/dev-python/rbintegrations/rbintegrations-1.0.1.ebuild
new file mode 100644
index 00000000..adca00e7
--- /dev/null
+++ b/dev-python/rbintegrations/rbintegrations-1.0.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A set of third-party service integrations for Review Board 3.0+"
+HOMEPAGE="https://www.reviewboard.org/"
+SRC_URI="https://downloads.reviewboard.org/releases/${PN}/$(ver_cut 1-2)/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-python/asana[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ =dev-util/reviewboard-3.0*[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_unpack() {
+ default
+
+ cd "${S}"
+ npm install less@2.5.0 less-plugin-autoprefix@1.5.1 uglify-js@2.4.10 babel-cli@6.5.1 babel-preset-es2015@6.5.0 babel-plugin-dedent@2.0.0 || die
+}
+
+python_prepare() {
+ :
+}
+
+src_install() {
+ pushd "${HOME}" || die
+ ln -s "${WORKDIR}/rbintegrations-${PV}/node_modules" .node_modules || die
+ popd || die
+ distutils-r1_src_install
+}