summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2021-08-07 09:14:56 +0200
committerHans de Graaff <hans@degraaff.org>2021-08-07 09:14:56 +0200
commit6e62d5f507f81f91bd0812947416e73291f34510 (patch)
tree19f2f1f5ff1638534eff7a3364333c5c5b7c40c8 /dev-ruby/rubocop-ast/rubocop-ast-1.4.1.ebuild
parentdev-ruby/global_phone_dbgen: add ruby30; EAPI 8 (diff)
downloadgraaff-6e62d5f507f81f91bd0812947416e73291f34510.tar.gz
graaff-6e62d5f507f81f91bd0812947416e73291f34510.tar.bz2
graaff-6e62d5f507f81f91bd0812947416e73291f34510.zip
dev-ruby/rubocop-ast: cleanup
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Hans de Graaff <hans@degraaff.org>
Diffstat (limited to 'dev-ruby/rubocop-ast/rubocop-ast-1.4.1.ebuild')
-rw-r--r--dev-ruby/rubocop-ast/rubocop-ast-1.4.1.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-ruby/rubocop-ast/rubocop-ast-1.4.1.ebuild b/dev-ruby/rubocop-ast/rubocop-ast-1.4.1.ebuild
deleted file mode 100644
index 1324a0ea..00000000
--- a/dev-ruby/rubocop-ast/rubocop-ast-1.4.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_GEMSPEC="rubocop-ast.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="RuboCop's Node and NodePattern classes"
-HOMEPAGE="https://github.com/rubocop-hq/rubocop-ast"
-SRC_URI="https://github.com/rubocop-hq/rubocop-ast/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="1"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/parser-2.7.1.5
-"
-
-ruby_add_bdepend "dev-ruby/bundler dev-ruby/oedipus_lex dev-ruby/racc"
-
-all_ruby_prepare() {
- sed -i -e '3irequire "uri"' spec/spec_helper.rb || die
- sed -i -e '1irequire "oedipus_lex"' tasks/compile.rake || die
-
- # Avoid unneeded dependencies
- rm -f tasks/cut_release.rake || die
- sed -e "/\(gemspec\|bump\|pry\|'rubocop\|simplecov\)/ s:^:#:" \
- -e '/rake/ s/~> 13.0/>= 12/' \
- -i Gemfile || die
-}
-
-each_ruby_prepare() {
- sed -i -e "s:bundle exec:${RUBY} -S:" tasks/compile.rake || die
-}
-
-each_ruby_compile() {
- ${RUBY} -S rake generate || die
-}