summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/bootstrap/bootstrap-5.3.3.ebuild')
-rw-r--r--dev-ruby/bootstrap/bootstrap-5.3.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/bootstrap/bootstrap-5.3.3.ebuild b/dev-ruby/bootstrap/bootstrap-5.3.3.ebuild
new file mode 100644
index 00000000..e15ceb66
--- /dev/null
+++ b/dev-ruby/bootstrap/bootstrap-5.3.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+# Requires capybara + poltergeist
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_EXTRAINSTALL="assets"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Bootstrap 5 rubygem for Rails / Sprockets / Hanami / etc"
+HOMEPAGE="https://github.com/twbs/bootstrap-rubygem"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="$(ver_cut 1-2)"
+IUSE=""
+
+# A sass engine is required, but we only package sassc-rails at the moment.
+ruby_add_rdepend "
+ >=dev-ruby/autoprefixer-rails-9.1.0:*
+ >=dev-ruby/popper_js-2.11.8:2
+ >=dev-ruby/sassc-rails-2.0.0
+"
+
+all_ruby_prepare() {
+ sed -i -e '/reporters/I s:^:#:' test/test_helper.rb || die
+}