summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/enumerable-statistics/enumerable-statistics-2.0.8.ebuild')
-rw-r--r--dev-ruby/enumerable-statistics/enumerable-statistics-2.0.8.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/enumerable-statistics/enumerable-statistics-2.0.8.ebuild b/dev-ruby/enumerable-statistics/enumerable-statistics-2.0.8.ebuild
new file mode 100644
index 00000000..4e3db35a
--- /dev/null
+++ b/dev-ruby/enumerable-statistics/enumerable-statistics-2.0.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="enumerable-statistics.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/enumerable/statistics/extension/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR=lib/enumerable/statistics
+
+inherit ruby-fakegem
+
+DESCRIPTION="This library provides statistics features for Enumerable"
+HOMEPAGE="https://github.com/mrkn/enumerable-statistics"
+SRC_URI="https://github.com/mrkn/enumerable-statistics/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}