summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/inifile/inifile-3.0.0.ebuild')
-rw-r--r--dev-ruby/inifile/inifile-3.0.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/inifile/inifile-3.0.0.ebuild b/dev-ruby/inifile/inifile-3.0.0.ebuild
new file mode 100644
index 00000000..dc8be57d
--- /dev/null
+++ b/dev-ruby/inifile/inifile-3.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Native Ruby package for reading and writing INI files"
+HOMEPAGE="https://github.com/twp/inifile"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/${P}-tainted.patch" )
+
+all_ruby_prepare() {
+ # Taint has been removed from ruby and not done anything since ruby 2.7
+ sed -e '/test_taint/,/^ end/ s:^:#:' \
+ -e '/taint/ s:^:#:' \
+ -i test/test_inifile.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e "Dir['test/test_*.rb'].each { require _1 }" || die
+}