summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/inky-rb/inky-rb-1.4.2.0.ebuild')
-rw-r--r--dev-ruby/inky-rb/inky-rb-1.4.2.0.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-ruby/inky-rb/inky-rb-1.4.2.0.ebuild b/dev-ruby/inky-rb/inky-rb-1.4.2.0.ebuild
index abc7b0e3..2490f6f6 100644
--- a/dev-ruby/inky-rb/inky-rb-1.4.2.0.ebuild
+++ b/dev-ruby/inky-rb/inky-rb-1.4.2.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30"
+USE_RUBY="ruby30 ruby31 ruby32"
RUBY_FAKEGEM_EXTRADOC="README.md"
@@ -11,7 +11,7 @@ RUBY_FAKEGEM_RECIPE_TEST="rspec3"
inherit ruby-fakegem
DESCRIPTION="A templating language that converts simple HTML into responsive email-ready HTML"
-HOMEPAGE="https://github.com/zurb/inky-rb"
+HOMEPAGE="https://github.com/foundation/inky-rb"
LICENSE="MIT"
KEYWORDS="~amd64"
@@ -34,4 +34,9 @@ all_ruby_prepare() {
rm -f Gemfile.lock || die
sed -i -e '/rubocop/I s:^:#:' -e '/bundler/I s:^:#:' Rakefile || die
sed -i -e '/rubocop/ s:^:#:' inky.gemspec || die
+
+ # Avoid tests depending on old versions of slim
+ sed -e '/when configured to use a different template engine/ s/context/xcontext/' \
+ -e '/(like slim)/ s/it/xit/' \
+ -i spec/test_app/spec/features/inky_spec.rb || die
}