summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rspec-activemodel-mocks/rspec-activemodel-mocks-1.2.0.ebuild')
-rw-r--r--dev-ruby/rspec-activemodel-mocks/rspec-activemodel-mocks-1.2.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/rspec-activemodel-mocks/rspec-activemodel-mocks-1.2.0.ebuild b/dev-ruby/rspec-activemodel-mocks/rspec-activemodel-mocks-1.2.0.ebuild
new file mode 100644
index 00000000..4a639c3d
--- /dev/null
+++ b/dev-ruby/rspec-activemodel-mocks/rspec-activemodel-mocks-1.2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="RSpec test doubles for ActiveModel and ActiveRecord"
+HOMEPAGE="https://github.com/rspec/rspec-activemodel-mocks"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activesupport-3.0:*
+ >=dev-ruby/activemodel-3.0:*
+ >=dev-ruby/rspec-mocks-2.99:* <dev-ruby/rspec-mocks-4:*"
+
+ruby_add_bdepend "test? ( dev-ruby/activerecord[sqlite] )"