summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rubocop-rspec/rubocop-rspec-2.11.1.ebuild')
-rw-r--r--dev-ruby/rubocop-rspec/rubocop-rspec-2.11.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/rubocop-rspec/rubocop-rspec-2.11.1.ebuild b/dev-ruby/rubocop-rspec/rubocop-rspec-2.11.1.ebuild
new file mode 100644
index 00000000..6a5ce441
--- /dev/null
+++ b/dev-ruby/rubocop-rspec/rubocop-rspec-2.11.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRAINSTALL="config"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="rubocop-rspec.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Code style checking for RSpec files"
+HOMEPAGE="https://github.com/rubocop-hq/rubocop-rspec"
+SRC_URI="https://github.com/rubocop-hq/rubocop-rspec/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ =dev-ruby/rubocop-1* >=dev-ruby/rubocop-1.19
+"