summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rubocop/rubocop-0.59.0.ebuild')
-rw-r--r--dev-ruby/rubocop/rubocop-0.59.0.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-ruby/rubocop/rubocop-0.59.0.ebuild b/dev-ruby/rubocop/rubocop-0.59.0.ebuild
deleted file mode 100644
index cdac626d..00000000
--- a/dev-ruby/rubocop/rubocop-0.59.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_EXTRAINSTALL="assets config"
-RUBY_FAKEGEM_BINDIR="exe"
-
-inherit eapi7-ver ruby-fakegem
-
-DESCRIPTION="A Ruby static code analyzer"
-HOMEPAGE="https://github.com/bbatsov/rubocop"
-SRC_URI="https://github.com/bbatsov/rubocop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend "
- =dev-ruby/jaro_winkler-1.5*
- >=dev-ruby/parallel-1.10:1
- >=dev-ruby/parser-2.5:0
- >=dev-ruby/powerpack-0.1:0
- >=dev-ruby/rainbow-2.2.2:2
- >=dev-ruby/ruby-progressbar-1.7:0
- >=dev-ruby/unicode-display_width-1.0.1:1"
-
-ruby_add_bdepend "test? ( dev-ruby/safe_yaml dev-ruby/webmock )"
-
-all_ruby_prepare() {
- sed -i -e '/pry/ s:^:#:' spec/spec_helper.rb || die
-
- # Remove failing spec, to be investigated later.
- rm spec/rubocop/formatter/json_formatter_spec.rb || die
-
- sed -i -e 's:/tmp/example:'${TMPDIR}'/example:' spec/rubocop/cop/team_spec.rb || die
-}